summaryrefslogtreecommitdiffhomepage
path: root/tests/15_test_DebianSource.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/15_test_DebianSource.py')
-rw-r--r--tests/15_test_DebianSource.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/15_test_DebianSource.py b/tests/15_test_DebianSource.py
index efc38b4f..06ffb78b 100644
--- a/tests/15_test_DebianSource.py
+++ b/tests/15_test_DebianSource.py
@@ -110,3 +110,11 @@ class TestDebianSource(testutils.DebianGitTestRepo):
source = DebianSource('.')
self.assertEquals(source.changelog.distribution, "UNRELEASED")
self.assertFalse(source.is_releasable())
+
+ def test_control(self):
+ os.makedirs('debian/')
+ with open('debian/control', 'w') as f:
+ f.write("Source: foo")
+ source = DebianSource('.')
+ self.assertIsNotNone(source.control)
+ self.assertEquals(source.control.name, "foo")