aboutsummaryrefslogtreecommitdiffhomepage
path: root/tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec
diff options
context:
space:
mode:
Diffstat (limited to 'tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec')
-rw-r--r--tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec b/tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec
new file mode 100644
index 00000000..38b07e48
--- /dev/null
+++ b/tests/data/rpm/rpmbuild/SPECS/gbp-test-native.spec
@@ -0,0 +1,34 @@
+Name: gbp-test-native
+Summary: Test package for git-buildpackage
+Version: 1.0
+Release: 1
+Group: Development/Libraries
+License: GPLv2
+Source1: %{name}-%{version}.zip
+BuildRequires: unzip
+
+%description
+Package for testing the RPM functionality of git-buildpackage.
+Mimics a "native" package
+
+
+%prep
+unzip %{SOURCE1}
+%setup -T -D
+
+
+%build
+make
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}/%{_datadir}/%{name}
+cp -R * %{buildroot}/%{_datadir}/%{name}
+
+
+
+%files
+%defattr(-,root,root,-)
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}