summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2021-03-17 16:53:19 +0100
committerGuido Günther <agx@sigxcpu.org>2021-03-17 16:53:19 +0100
commitb8e590026e887c79d430444cb7e0c58a3493bfe3 (patch)
treec4fea9b54680bda0e7a54d0fe5f93e057cab3b1f
parent91de0d1c2cc5defe4db583efe123b05a7ca8b5bb (diff)
parent8edc5391cb5cbecd846a2d94a046d45f672086a7 (diff)
Merge tag 'debian/0.0.4-2' into debian/buster
ldapsp Debian release 0.0.4-2
-rw-r--r--debian/changelog10
-rw-r--r--debian/control3
-rw-r--r--debian/copyright2
-rw-r--r--debian/patches/ldap-Add-add-delete-with-timeout.patch45
-rw-r--r--debian/patches/series1
5 files changed, 58 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 8fc912a..25c7d02 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ldapsp (0.0.4-2) unstable; urgency=medium
+
+ * d/control: Drop dh-systemd.
+ Handled by debhelper.
+ * d/copyright: Update URL
+ * d/control: Bump standards version
+ * ldap: Add add/delete with timeout
+
+ -- Guido Günther <agx@sigxcpu.org> Wed, 17 Mar 2021 16:51:58 +0100
+
ldapsp (0.0.4-1~bpo10+1) buster; urgency=medium
* Buster backport
diff --git a/debian/control b/debian/control
index 284aef0..b0ea12e 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,11 @@ Section: admin
Priority: optional
Maintainer: Guido Günther <agx@sigxcpu.org>
Build-Depends: debhelper-compat (= 12),
- dh-systemd,
erlang,
# since we use ./rebar to fetch deps
ca-certificates,
git,
-Standards-Version: 3.9.8
+Standards-Version: 4.5.1
Package: ldapsp
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index 9425fc8..6c0a437 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: ldapsp
-Source: <url://example.com>
+Source: https://git.sigxcpu.org/cgit/ldapsp
Files: *
Copyright: 2016 Guido Günther <agx@sigxcpu.org>
diff --git a/debian/patches/ldap-Add-add-delete-with-timeout.patch b/debian/patches/ldap-Add-add-delete-with-timeout.patch
new file mode 100644
index 0000000..c94f7c1
--- /dev/null
+++ b/debian/patches/ldap-Add-add-delete-with-timeout.patch
@@ -0,0 +1,45 @@
+From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
+Date: Wed, 17 Mar 2021 16:17:20 +0100
+Subject: ldap: Add add/delete with timeout
+
+This allows to work with super slow ldap servers.
+
+(cherry picked from commit 8fdf25981878d9cb1820f6dccf187f877088e758)
+---
+ src/ldapsp_ldap.erl | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/src/ldapsp_ldap.erl b/src/ldapsp_ldap.erl
+index 48b1780..9a9be66 100644
+--- a/src/ldapsp_ldap.erl
++++ b/src/ldapsp_ldap.erl
+@@ -28,7 +28,9 @@
+ terminate/2, code_change/3,
+ %% API
+ add/2,
+- delete/1
++ add/3,
++ delete/1,
++ delete/2
+ ]).
+
+ -define(SERVER, ?MODULE).
+@@ -39,10 +41,18 @@
+ %%% API
+ %%%===================================================================
+
++-spec add(string(), list(), integer()) -> ok | {error,atom}.
++add(Dn, Attributes, Timeout) ->
++ gen_server:call(?SERVER, {add, Dn, Attributes}, Timeout).
++
+ -spec add(string(), list()) -> ok | {error,atom}.
+ add(Dn, Attributes) ->
+ gen_server:call(?SERVER, {add, Dn, Attributes}).
+
++-spec delete(string(), integer()) -> ok | {error,atom}.
++delete(Dn, Timeout) ->
++ gen_server:call(?SERVER, {delete, Dn}, Timeout).
++
+ -spec delete(string()) -> ok | {error,atom}.
+ delete(Dn) ->
+ gen_server:call(?SERVER, {delete, Dn}).
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..979ed72
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+ldap-Add-add-delete-with-timeout.patch