aboutsummaryrefslogtreecommitdiff
path: root/libplanfahr/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-10-15 09:24:00 +0200
committerGuido Günther <agx@sigxcpu.org>2015-05-07 09:47:12 +0200
commit6dc49293225cf01f1663b6c7387c283057b3c30a (patch)
tree9c7963ef0e613eae01be783be977db22a34d18c6 /libplanfahr/Makefile.am
parentea66ff6027b8f6a14da274a840f57fcd3bfb6556 (diff)
Create types for enums and flags
Diffstat (limited to 'libplanfahr/Makefile.am')
-rw-r--r--libplanfahr/Makefile.am36
1 files changed, 31 insertions, 5 deletions
diff --git a/libplanfahr/Makefile.am b/libplanfahr/Makefile.am
index f96cd13..82e8f43 100644
--- a/libplanfahr/Makefile.am
+++ b/libplanfahr/Makefile.am
@@ -2,7 +2,15 @@ include $(top_srcdir)/flymake.mk
SUBDIRS = providers tests
-EXTRA_DIST = libplanfahr.sym
+EXTRA_DIST = libplanfahr.sym \
+ lpf-enumtypes.c \
+ lpf-enumtypes.h \
+ $(NULL)
+
+BUILT_SOURCES = \
+ lpf-enumtypes.c \
+ lpf-enumtypes.h \
+ $(NULL)
lib_LTLIBRARIES = libplanfahr-0.0.la
@@ -17,7 +25,13 @@ PLANFAHR_HEADER_FILES = \
lpf-trip-part.h \
$(NULL)
+PLANFAHR_INCLUDE_HEADER_FILES = \
+ $(PLANFAHR_HEADER_FILES) \
+ lpf-enumtypes.h \
+ $(NULL)
+
PLANFAHR_SOURCE_FILES = \
+ lpf-enumtypes.c \
lpf-manager.c \
lpf-provider.c \
lpf-loc.c \
@@ -26,9 +40,17 @@ PLANFAHR_SOURCE_FILES = \
lpf-trip-part.c \
$(NULL)
+lpf-enumtypes.h: $(PLANFAHR_HEADER_FILES) lpf-enumtypes.h.template
+ $(AM_V_GEN) $(GLIB_MKENUMS) --template $(filter %.template,$^) $(filter-out %.template,$^) > \
+ lpf-enumtypes.h.tmp && mv lpf-enumtypes.h.tmp lpf-enumtypes.h
+
+lpf-enumtypes.c: $(PLANFAHR_HEADER_FILES) lpf-enumtypes.c.template
+ $(AM_V_GEN) $(GLIB_MKENUMS) --template $(filter %.template,$^) $(filter-out %.template,$^) > \
+ lpf-enumtypes.c.tmp && mv lpf-enumtypes.c.tmp lpf-enumtypes.c
+
libplanfahr_0_0_ladir = $(includedir)/libplanfahr-0.0/libplanfahr
libplanfahr_0_0_la_HEADERS = \
- $(PLANFAHR_HEADER_FILES) \
+ $(PLANFAHR_INCLUDE_HEADER_FILES) \
$(NULL)
libplanfahr_0_0_la_SOURCES = \
@@ -82,16 +104,20 @@ Lpf_0_0_gir_SCANNERFLAGS = \
$(NULL)
Lpf_0_0_gir_FILES = \
$(PLANFAHR_SOURCE_FILES:%=$(srcdir)/%) \
- $(PLANFAHR_HEADER_FILES:%=$(srcdir)/%) \
+ $(PLANFAHR_INCLUDE_HEADER_FILES:%=$(srcdir)/%) \
$(NULL)
girdir = $(datadir)/gir-1.0
nodist_gir_DATA = $(INTROSPECTION_GIRS)
-
typelibdir = $(libdir)/girepository-1.0
nodist_typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
-CLEANFILES = $(nodist_gir_DATA) $(nodist_typelib_DATA)
+CLEANFILES = \
+ $(nodist_gir_DATA) \
+ $(nodist_typelib_DATA) \
+ lpf-enumtypes.c \
+ lpf-enumtypes.h \
+ $(NULL)
endif # HAVE_INTROSPECTION