aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2008-11-20 16:07:23 +0100
committerGuido Guenther <agx@sigxcpu.org>2008-11-20 16:07:23 +0100
commit46da5766bdbe5cea8d16aedb4586b9b0c771664d (patch)
tree39b4cf53f27a512ef125a9736647fa37c00e3dd4
parent355bc2c825d2ca3e8ac28d3ebcd3b5cde7cb3721 (diff)
parent6f22440c3de32c1169779343c4b1900d1931dd75 (diff)
Merge commit '0.0.6' into debian
-rw-r--r--INSTALL5
-rw-r--r--Makefile5
-rw-r--r--README20
-rw-r--r--munin-libvirt-plugins-detect.in2
4 files changed, 25 insertions, 7 deletions
diff --git a/INSTALL b/INSTALL
index 789eb9d..72be58e 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,5 +1,6 @@
Installation is simple:
-make PLUGINDIR=/etc/munin/plugins install
-/etc/init.d/munin-node restart
+make install
+this will install the plugins into /usr/share/munin/plugins. See README on
+howto configure and enable the plugins.
diff --git a/Makefile b/Makefile
index 3e6f950..3bb7a73 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-VERSION=0.0.5
+VERSION=0.0.6
PACKAGE=munin-libvirt-plugins
SBINDIR=/usr/sbin
PLUGINDIR=/usr/share/munin/plugins
@@ -15,8 +15,9 @@ PYFILES=$(patsubst %,%.py,$(PLUGINS) $(DETECT))
all: $(DETECT)
install: build
- install -d $(DESTDIR)$(PLUGINDIR)
+ install -d $(DESTDIR)$(PLUGINDIR)
install -m 755 $(PLUGINS) $(DESTDIR)$(PLUGINDIR)
+ install -d $(DESTDIR)$(SBINDIR)
install -m 755 $(DETECT) $(DESTDIR)$(SBINDIR)
$(DETECT): $(DETECT).in
diff --git a/README b/README
index cbb8ab0..4b758c1 100644
--- a/README
+++ b/README
@@ -2,14 +2,30 @@ This is a set of munin plugins to monitor virtual machines managed via libvirt.
See INSTALL for installation instructions.
-The default uri used to connect to libvirt is "qemu:///system". This can be
-changed in the plugin configuration:
+== Setting things up ==
+
+Autoconfiguration is simple. Run:
+
+ munin-libvirt-plugins-detect
+
+this will try to detect the hypervisor, create an apropriate configuration and
+enable all plugins.
+
+If you prefer to configure things by hand: The default uri used to connect to
+libvirt is "qemu:///system". This can be changed in the plugin configuration:
cat <<EOF >/etc/munin/plugin-conf.d/libvirt
[libvirt-*]
env.uri xen:///
EOF
+Enabling plugins by hand is the same as with any other munin plugin:
+
+ ln -s /usr/share/munin/plugins/libvirt-<plugin> /etc/munin/plugins/
+ /etc/init.d/munin-node restart
+
+== Plugin Configuration ==
+
libvirt-mem and libvirt-cputime support limits[1] for critical and warning
values. These are set to 90% (warning) and 95% (critical) by default. However
you can change them in /etc/munin/munin.conf:
diff --git a/munin-libvirt-plugins-detect.in b/munin-libvirt-plugins-detect.in
index 29012d3..275c987 100644
--- a/munin-libvirt-plugins-detect.in
+++ b/munin-libvirt-plugins-detect.in
@@ -1,4 +1,4 @@
-#/!/usr/bin/python
+#!/usr/bin/python
# vim: set fileencoding=utf-8 :
#
# Configure and enable munin libvirt plugins