summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 24174e0..ad796f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,13 +17,23 @@ nmvpnservicedir = $(NM_VPN_SERVICE_DIR)
nmvpnservice_DATA = nm-iodine-service.name
if WITH_LIBNM_GLIB
-nmvpnoldservicedir = $(sysconfdir)/NetworkManager/VPN
-nmvpnoldservice_DATA = nm-iodine-service.name
+# Install a file with full path to plugins for an old gnome-shell
+# https://bugzilla.gnome.org/show_bug.cgi?id=693590
+install-data-hook:
+ mkdir -p $(DESTDIR)$(sysconfdir)/NetworkManager/VPN
+ sed -e "1s|^|# This file is obsoleted by a file in $(NM_VPN_SERVICE_DIR)\n\n|" \
+ -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' \
+ -e 's|[@]PLUGINDIR[@]|$(libdir)/NetworkManager|g' \
+ <$(srcdir)/nm-iodine-service.name.in \
+ >$(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-iodine-service.name
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-iodine-service.name
endif
nm-iodine-service.name: $(srcdir)/nm-iodine-service.name.in
sed -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' \
- -e 's|[@]PLUGINDIR[@]|$(libdir)/NetworkManager|g' \
+ -e 's|[@]PLUGINDIR[@]/|@NM_PLUGIN_DIR@|g' \
$< >$@
DISTCHECK_CONFIGURE_FLAGS = --enable-more-warnings=yes