summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2007-04-27 18:13:23 +0200
committerGuido Guenther <agx@bogon.sigxcpu.org>2007-04-27 18:13:23 +0200
commit47fd70d1246db98d14ad92a8207fbd9ac4bf4b4a (patch)
tree4f9e986f276bd28ef4786ce67c3f025b1e288130
parent31505e9558b6a403bd3e5639608d918d6ef1b11f (diff)
readd debian dir
-rw-r--r--debian/changelog14
-rw-r--r--debian/compat1
-rw-r--r--debian/control13
-rw-r--r--debian/copyright10
-rw-r--r--debian/docs1
-rw-r--r--debian/rules108
6 files changed, 147 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6028f57
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,14 @@
+libpam-exec (0.2-1) unstable; urgency=low
+
+ * pass password in the environment variable "PASSWD"
+ * remove some superflous automake stuff
+ * use _pam_log everywhere
+
+ -- Guido Guenther <agx@debian.org> Tue, 7 Feb 2006 15:16:05 +0100
+
+libpam-exec (0.1-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Guido Guenther <agx@debian.org> Fri, 28 Oct 2005 20:52:35 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..afdf5b0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: libpam-exec
+Section: net
+Priority: optional
+Maintainer: Guido Guenther <agx@debian.org>
+Build-Depends: debhelper (>= 4.0.0), autotools-dev
+Standards-Version: 3.6.2
+
+Package: libpam-exec
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: pam module to exec an arbitrary program
+ This module allows you to call out arbitray programs, they
+ get the current user, ruser, tty, etc. as arguments
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..a20d0c4
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,10 @@
+This package was debianized by Guido Guenther <agx@debian.org> on
+Fri, 28 Oct 2005 20:52:35 +0200.
+
+It was downloaded from <fill in ftp site>
+
+Copyright Holder: <put author(s) name and email here>
+
+License:
+
+<Put the license of the package here>
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 0000000..3d78705
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,108 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+config.status: configure
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --libdir=/lib
+
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/libpam-exec.sgml > libpam-exec.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) distclean
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ rm -f config.log
+
+
+ dh_clean --exclude ./pam_warn.c.orig
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k --exclude ./pam_warn.c.orig
+ dh_installdirs
+
+ # Add here commands to install the package into debian/libpam-exec.
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/libpam-exec
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install