aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-05-01 13:46:09 +0200
committerGuido Günther <agx@sigxcpu.org>2011-05-01 14:28:32 +0200
commit4b4c334827a8639c246bcbc717288a133d55b754 (patch)
tree211efaf2d30c6fc60916fcbb926c5ab51f658393 /configure.ac
parent8981216d64d501530549836c49fc2844466f9de6 (diff)
Check for dependencies
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e35224f..39bcb9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,16 @@ AM_INIT_AUTOMAKE([-Wno-portability])
IT_PROG_INTLTOOL([0.35.0])
+GLIB_REQUIRED=2.25.6
+GTK_REQUIRED=3.0.0
+PYGOBJECT_REQUIRED=2.28.3
+DBUS_PYTHON_REQUIRED=0.83
+
+PKG_CHECK_MODULES(PPM, [glib-2.0 >= $GLIB_REQUIRED
+ gtk+-3.0 >= $GTK_REQUIRED
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ dbus-python >= $DBUS_PYTHON_REQUIRED])
+
GETTEXT_PACKAGE=prepaid-manager-applet
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package])