summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-02-12 17:13:48 +0100
committerGuido Günther <agx@sigxcpu.org>2010-02-12 17:13:48 +0100
commit94eb78c65419d201394a8636d26726e44424503d (patch)
treee7a65460b76632fe16a941bafb2f70aca4b474b6
parent1c2e7c06044906ab8668d2de03c73191b1067472 (diff)
Exclude 64bit libs on 32bit build and vice versa
-rw-r--r--make-sgpkg.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/make-sgpkg.py b/make-sgpkg.py
index 60e2c07..9fbf2d4 100644
--- a/make-sgpkg.py
+++ b/make-sgpkg.py
@@ -106,12 +106,16 @@ def gen_install(debiandir):
def gen_rules(debiandir, arch):
- # ia32 libs is lacking KDE and Gnome libs:
- excludes = [ "libKde3Connect.so", "libGnomeConnect.so" ]
if arch == "amd64":
- amd64_ignore = " ".join([ "--exclude=%s" % e for e in excludes ])
+ # ignore 32bit libs on amd64
+ excludes = [ "libGnomeConnect.so", "libJPlatin.so" ]
+ # these were additionally shipped with 719:
+ excludes += [ "libKde3Connect.so" ]
else:
- amd64_ignore = ""
+ # ignore 64bit libs on i386
+ excludes = [ "libGnomeConnect64.so", "libJPlatin64.so" ]
+ ignore_libs = " ".join([ "--exclude=%s" % e for e in excludes ])
+
contents = """#!/usr/bin/make -f
export DH_COMPAT=5
@@ -121,7 +125,7 @@ include /usr/share/cdbs/1/rules/debhelper.mk
install/sapgui::
rm -rf dest/usr/lib/sapgui/SAPGUI
-""" % amd64_ignore
+""" % ignore_libs
write_file(debiandir, "rules", contents)
os.chmod(os.path.join(debiandir,"rules"), 0755)