summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:25 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:25 +0100
commit3dbe8df8bfe8741e1b9a48b56e41517816f17dc1 (patch)
tree26957efbc9bc5417767a01664665f3e0ce2cbc79 /Makefile.am
parent10d15c65fd10614c4085af390a9fbf390ab958b7 (diff)
Imported Upstream version 0.4.997upstream/0.4.997
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 309bda1..bcfca11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ GENERATED_FILES = \
docs/spec.html: $(XMLS) introspection/all.xml doc-generator.xsl
@install -d docs
- $(XSLTPROC) doc-generator.xsl introspection/all.xml > $@
+ $(XSLTPROC) $(top_srcdir)/doc-generator.xsl $(top_srcdir)/introspection/all.xml > $@
all: $(GENERATED_FILES)
@@ -49,7 +49,7 @@ include_HEADERS = include/mm-modem.h
include/mm-modem.h: $(XMLS) introspection/all.xml header-generator.xsl
@install -d include
- $(XSLTPROC) header-generator.xsl introspection/all.xml > $@
+ $(XSLTPROC) $(top_srcdir)/header-generator.xsl $(top_srcdir)/introspection/all.xml > $@
%service: %service.in
$(edit) $< >$@
@@ -63,7 +63,10 @@ edit = @sed \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
-e 's|@libexecdir[@]|$(libexecdir)|g'
-DISTCHECK_CONFIGURE_FLAGS = --with-udev-base-dir=$dc_install_base --with-tests=yes
+DISTCHECK_CONFIGURE_FLAGS = \
+ --with-udev-base-dir="$$dc_install_base" \
+ --with-tests=yes \
+ --with-docs=yes
INTLTOOL_FILES = \
intltool-extract.in \