aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/qdl-blacklist.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/qdl-blacklist.patch')
-rw-r--r--debian/patches/qdl-blacklist.patch111
1 files changed, 111 insertions, 0 deletions
diff --git a/debian/patches/qdl-blacklist.patch b/debian/patches/qdl-blacklist.patch
new file mode 100644
index 0000000..6f64d82
--- /dev/null
+++ b/debian/patches/qdl-blacklist.patch
@@ -0,0 +1,111 @@
+From: Mathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>
+Subject: Add blacklists for Gobi QDL devices (devices before firmware load)
+Bug-Ubuntu: http://launchpad.net/bugs/686418
+
+Blacklist a number of device IDs that happen to be "QDL" devices, only used
+as an initial state device to then load the firmware used by the actual modem
+devices.
+
+Because these devices do nothing but load firmware, we shouldn't try to
+initialize them in ModemManager, it just fails.
+
+Thanks to Jochen Gruse for the work to generate this list. See LP bug 686418
+for the details.
+
+Index: modemmanager-0.4+git.20110124t203624.00b6cce/src/77-mm-qdl-device-blacklist.rules
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ modemmanager-0.4+git.20110124t203624.00b6cce/src/77-mm-qdl-device-blacklist.rules 2011-01-26 20:18:45.000000000 -0500
+@@ -0,0 +1,80 @@
++# do not edit this file, it will be overwritten on update
++
++ACTION!="add|change", GOTO="mm_qdl_device_blacklist_end"
++
++# Acer Gobi QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9211", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# HP un2400 Gobi QDL Device
++ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="201d", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Panasonic Gobi QDL device
++ATTRS{idVendor}=="04da", ATTRS{idProduct}=="250c", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Dell Gobi QDL device
++ATTRS{idVendor}=="413c", ATTRS{idProduct}=="8171", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Novatel Gobi QDL device
++ATTRS{idVendor}=="1410", ATTRS{idProduct}=="a008", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Asus Gobi QDL device
++ATTRS{idVendor}=="0b05", ATTRS{idProduct}=="1774", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# ONDA Gobi QDL device
++ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="fff2", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# OQO Gobi QDL device
++ATTRS{idVendor}=="1557", ATTRS{idProduct}=="0a80", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Generic Gobi QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9008", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Generic Gobi QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9201", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Generic Gobi QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9221", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Generic Gobi QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9231", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Unknown Gobi QDL device
++ATTRS{idVendor}=="1f45", ATTRS{idProduct}=="0001", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Dell Gobi 2000 QDL device (N0218, VU936)
++ATTRS{idVendor}=="413c", ATTRS{idProduct}=="8185", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Generic Gobi 2000 QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9208", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Sony Gobi 2000 QDL device (N0279, VU730)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9224", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Samsung Gobi 2000 QDL device (VL176)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9244", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# HP Gobi 2000 QDL device (VP412)
++ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="241d", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Acer Gobi 2000 QDL device (VP413)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9214", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Asus Gobi 2000 QDL device (VR305)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9264", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Top Global Gobi 2000 QDL device (VR306)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9234", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# iRex Technologies Gobi 2000 QDL device (VR307)
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9274", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Sierra Wireless Gobi 2000 QDL device (VT773)
++ATTRS{idVendor}=="1199", ATTRS{idProduct}=="9000", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# CMDTech Gobi 2000 QDL device (VU922)
++ATTRS{idVendor}=="16d8", ATTRS{idProduct}=="8001", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++# Gobi 2000 QDL device
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", ENV{ID_MM_DEVICE_IGNORE}="1"
++
++LABEL="mm_qdl_device_blacklist_end"
+Index: modemmanager-0.4+git.20110124t203624.00b6cce/src/Makefile.am
+===================================================================
+--- modemmanager-0.4+git.20110124t203624.00b6cce.orig/src/Makefile.am 2011-01-26 20:19:16.259452829 -0500
++++ modemmanager-0.4+git.20110124t203624.00b6cce/src/Makefile.am 2011-01-26 20:19:59.871751441 -0500
+@@ -3,6 +3,7 @@
+ udevrulesdir = $(UDEV_BASE_DIR)/rules.d
+ udevrules_DATA = \
+ 77-mm-usb-device-blacklist.rules \
++ 77-mm-qdl-device-blacklist.rules \
+ 77-mm-pcmcia-device-blacklist.rules \
+ 77-mm-platform-serial-whitelist.rules \
+ 80-mm-candidate.rules