summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile22
-rw-r--r--d-push-popcon.pngbin0 -> 7236 bytes
-rw-r--r--debian.pdfbin0 -> 175733 bytes
-rw-r--r--debian.tex217
-rw-r--r--openlogo-nd.pdfbin0 -> 3168 bytes
5 files changed, 239 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d0d0bad
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+NAME = debian
+DEPS = $(wildcard *.tex)
+
+all: pdf
+pdf: $(NAME).pdf
+dvi: $(NAME).dvi
+
+$(NAME).pdf $(NAME).dvi: $(DEPS)
+
+clean::
+ -rm -f *.toc *.cgm *.nav *.log *.out *.aux *.snm *.*~ *.vrb
+
+present:
+ killall pidgin krb5-auth-dialog
+ xrandr --output$(OUTPUT) --auto
+ gnome-screensaver-command -i &
+ #xpdf -fullscreen $(TARGET)
+ evince -s --page-label=1 $(TARGET)
+
+# Debian package: latex-make
+include /usr/include/LaTeX.mk
+
diff --git a/d-push-popcon.png b/d-push-popcon.png
new file mode 100644
index 0000000..792afcf
--- /dev/null
+++ b/d-push-popcon.png
Binary files differ
diff --git a/debian.pdf b/debian.pdf
new file mode 100644
index 0000000..8d2ab88
--- /dev/null
+++ b/debian.pdf
Binary files differ
diff --git a/debian.tex b/debian.tex
new file mode 100644
index 0000000..7ac771d
--- /dev/null
+++ b/debian.tex
@@ -0,0 +1,217 @@
+% Debian, Groupware and You
+%
+% (c) 2011 Guido Günther <agx@sigxcpu.org>
+%
+% CC BY-SA 3.0
+%
+% Some ideas borrowed from Zack's LCA 2011 talk
+
+\documentclass[compress]{beamer}
+\mode<presentation>
+{
+ \usetheme{Warsaw}
+ \setbeamertemplate{footline}{}
+ \setbeamertemplate{headline}{}
+}
+\usepackage[english]{babel}
+
+\usepackage[utf8]{inputenc}
+
+\logo{\includegraphics[viewport=274 335 360 440,width=1cm]{openlogo-nd.pdf}}
+
+\usepackage{times}
+\usepackage[T1]{fontenc} \title{Debian, Groupware and You}
+\usepackage{pifont}
+
+\author[Guido Günther]
+{
+Guido Günther
+{\it <agx@debian.org>}
+}
+
+\institute[Debian]{Debian Developer}
+\date[ZS 2011]{Zarafa Summercamp 2011}
+
+\begin{document}
+
+\begin{frame}
+ \titlepage
+\end{frame}
+
+\begin{frame}\frametitle<presentation>{Overview}
+ \tableofcontents
+\end{frame}
+
+\section{Debian}
+\begin{frame}
+\frametitle{Debian - The Universal Operating System \#1}
+ \begin{itemize}
+ \item Architectures:
+ \begin{itemize}
+ \item Linux: amd64, armel, i386, ia64, mips, mipsel, powerpc, s390, sparc
+ % hppa, alpha
+ \item kFreeBSD: kfreebsd-amd64, kfreebsd-i386\\$\rightarrow$ zfs, dtrace, pf
+ \end{itemize}
+ \item (Security) support for all packages - no 2nd class packages
+ \item Released, when it's done: 11 Releases
+ \item Sid: \textasciitilde16000 source, \textasciitilde32000 binary-packages
+ \end{itemize}
+\end{frame}
+
+\begin{frame}
+\frametitle{Debian - The Universal Operating System \#2}
+ \begin{itemize}
+ \item Announced 1993
+ \item Debian Social Contract (1997)
+ % 100% Free Software
+ % Give back
+ % Don’t hide problems
+ % Priorities: users & Free Software
+ \item Debian Free Software Guidelines
+ % Strong rules regarding Free Software
+ \item Developers (900), maintainers (120), lots of contributors
+ % DMs exist since 2007 (DM-Upload-Allowed)
+ % DMs advocated by DDs
+ % contributors have uploads sponsored
+ % http://ftp-master.debian.org/dm-uploaders.html
+ \item 130 downstream distributions\footnote{according to distrowatch.com}: aptosid, grml, ucs, Ubuntu, Skolelinux, LinEx, ...
+ \item Not (single) company backed
+ \item Quality focus:
+ \begin{itemize}
+ \item Packaging policy
+ \item Testing: archive rebuilds, piuparts, lintian
+ \end{itemize}
+ \end{itemize}
+\end{frame}
+
+\section{Debian Groupware Meetings}
+\begin{frame}
+\frametitle{Debian Groupware Meetings}
+ % What do we ship? Evolution, Kontacts, Icedove/Iceowl, Contacts, Dates, Claws
+ \begin{itemize}
+ \item When, Where: During April at Linuxhotel, Essen, Germany
+ \item Focus:
+ \begin{itemize}
+ \item Packaging and integration of groupware related software into
+ Debian
+ \item Interoperability testing and fixing
+ \item Bug fixing
+ \item Fun
+ \end{itemize}
+ \item Free form:
+ \begin{itemize}
+ \item No schedule
+ \item No talks
+ \item Topics are collected in the Wiki (\url{http://wiki.debian.org/Groupware})
+ \end{itemize}
+ \item Mailing list:
+ \begin{itemize}
+ \item \small{\url{http://lists.alioth.debian.org/mailman/listinfo/calendarserver-discuss}}
+ \end{itemize}
+ \item Small group, newcomers welcome
+ \end{itemize}
+\end{frame}
+
+\section{Z-Push in Debian}
+\begin{frame}[fragile]
+\frametitle{Z-Push in Debian \#1}
+\begin{itemize}
+ \item First packages created with 1.3RC3 during 3rd DGM
+ \item License GPLv2
+\pause
+{ \tiny
+\begin{verbatim}
+NOTE: According to sec. 8 of the GNU General Public License (GPL),
+Version 2, the distribution of the Program in or to the
+United States of America is excluded from the scope of this license.
+The Program is licensed under GPL Version 2 only.
+\end{verbatim}}
+ \item What to do? \pause Very helpful discussions with Zarafa!
+\end{itemize}
+\end{frame}
+
+\begin{frame}[fragile]
+\frametitle{Z-Push in Debian \#2}
+\begin{itemize}
+ \item Z-Push Version 1.5 is AGPL 3 - great!
+\pause
+{ \tiny
+\begin{verbatim}
+* However, if you propagate an unmodified version of the Program you are
+* allowed to use the term "Z-Push" to indicate that you distribute the Program.
+* Furthermore you may use our trademarks where it is necessary to indicate
+* the intended purpose of a product or service provided you use it in accordance
+* with honest practices in industrial or commercial matters.
+* If you want to propagate modified versions of the Program under the name "Z-Push",
+* you may only do so if you have a written permission by Zarafa Deutschland GmbH
+* (to acquire a permission please contact Zarafa at trademark@zarafa.com).
+\end{verbatim}}
+ \pause
+ \item Patching is problematic
+ \item Not feasible for downstream distributions
+ \item What to do? \pause Very helpful discussions with Zarafa!
+ \item $\rightarrow$ Rebrand to d-push
+\end{itemize}
+\end{frame}
+
+\begin{frame}
+\frametitle{Z-Push in Debian \#3}
+ \includegraphics[width=8cm]{d-push-popcon.png}
+\end{frame}
+
+\section{Zarafa and Debian}
+\begin{frame}
+\frametitle{Zarafa and Debian}
+\begin{itemize}
+ \item Zarafa Attachment Drag ‘n’ Drop Extension: xul-ext-zarafa-drag-n-drop \ding{52}
+ \item Z-Push packaged: d-push \ding{52}
+ \pause
+ \item ZCP not yet packaged {\it in} Debian, but {\it for} Debian (i386, amd64)
+ \pause
+ \item Having it in Debian would make it run on kFreeBSD, other architectures
+ and shipped with derivatives.
+ \pause
+ \begin{itemize}
+ \item Licenses: AGPLv3 \ding{52}
+ \item Rebranding
+ \item Patches against libical, libvmime
+ \item Embedded copies of Smarty, fckeditor
+ \item Use Debconf
+ \end{itemize}
+
+\end{itemize}
+\end{frame}
+
+\begin{frame}
+\frametitle{Conclusions}
+\begin{itemize}
+ \item Let's integrate {\it ZCP OpenSource 7.0} into Debian!
+ \item Join us at the next Debian Groupware Meeting!
+\end{itemize}
+\end{frame}
+
+
+\begin{frame}
+\frametitle{Thank you}
+\begin{itemize}
+{\Large
+
+ \item Thanks!
+ \item Questions?\\[8ex]
+}
+{\tiny
+ \href{http://creativecommons.org/licenses/by-sa/3.0/}{CC BY-SA 3.0 ---
+ Creative Commons Attribution-ShareAlike 3.0}}
+\end{itemize}
+\end{frame}
+
+% Some ideas borrowed from Zack's LCA 2011 talk
+
+\end{document}
+
+% vim:et:ts=4:sw=4:et:sts=4:ai:set list listchars=tab\:»·,trail\:·:
+
+% LocalWords: org ShareAlike aptosid grml ucs Ubuntu Maemo Groupware
+% LocalWords: Kontact Icedove Iceowl aka Thunderbird groupware Sogo
+% LocalWords: Linuxhotel Openchange Calendarserver AGPL Zarafa
+% LocalWords: Rebrand kFreeBSD LocalWords
diff --git a/openlogo-nd.pdf b/openlogo-nd.pdf
new file mode 100644
index 0000000..fed3d93
--- /dev/null
+++ b/openlogo-nd.pdf
Binary files differ