aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-06-30 09:22:09 +0200
committerGuido Günther <agx@sigxcpu.org>2015-06-30 09:22:09 +0200
commite6ffcd9168c5eca1c0129e67d32b9783e5c5e5db (patch)
tree41880f252fd5fa4edb75df3047fb949a3b154303
parent796e63e0106f01fb581488c21679b9152121b94b (diff)
parenta2e8aeb34bc615cc9c0082951721971bb141f20a (diff)
Merge tag 'debian/0.0.10-1' into bpo/wheezy
whatmaps Debian release 0.0.10-1 Conflicts: debian/changelog
-rw-r--r--debian/changelog11
-rw-r--r--tests/test_distro.py8
-rwxr-xr-xwhatmaps/command.py3
-rw-r--r--whatmaps/debiandistro.py3
-rw-r--r--whatmaps/systemd.py4
5 files changed, 21 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 0074a87..9d1caef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+whatmaps (0.0.10-1) unstable; urgency=medium
+
+ * New upstream version 0.0.10:
+ * Add mapping for libvirt-daemon -> libvirtd. Needed for the sysv init
+ based systems
+ * Silence output if package list is empty
+ * Don't print overly long error message In the systemd case
+ * Fix assertRaises invocations. (Closes: #790372)
+
+ -- Guido Günther <agx@sigxcpu.org> Mon, 29 Jun 2015 19:18:02 +0200
+
whatmaps (0.0.9-1~bpo70+1) wheezy-backports; urgency=medium
* Rebuild for wheezy-backports.
diff --git a/tests/test_distro.py b/tests/test_distro.py
index 88fa984..409c1c6 100644
--- a/tests/test_distro.py
+++ b/tests/test_distro.py
@@ -36,10 +36,10 @@ class TestDistro(unittest.TestCase):
self.assertEqual(Distro.service_blacklist, set())
self.assertIsNone(Distro.id)
# Pure virtual methods
- self.assertRaises(Distro.pkg, None, None, NotImplementedError)
- self.assertRaises(Distro.pkg_by_file, None, NotImplementedError)
- self.assertRaises(Distro.restart_service_cmd, None, NotImplementedError)
- self.assertRaises(Distro.restart_service, None, NotImplementedError)
+ self.assertRaises(NotImplementedError, Distro.pkg, None)
+ self.assertRaises(NotImplementedError, Distro.pkg_by_file, None)
+ self.assertRaises(NotImplementedError, Distro.restart_service_cmd, None)
+ self.assertRaises(NotImplementedError, Distro.restart_service, None)
# Lookup methods
self.assertEqual(Distro.pkg_services(Pkg), [])
self.assertEqual(Distro.pkg_service_blacklist(Pkg), [])
diff --git a/whatmaps/command.py b/whatmaps/command.py
index d0f5c3e..c39b06d 100755
--- a/whatmaps/command.py
+++ b/whatmaps/command.py
@@ -81,7 +81,8 @@ def find_pkgs(procs, distro):
pkg.procs = [ proc ]
pkgs[pkg.name] = pkg
- logging.info("Packages that ship the affected binaries:")
+ if pkgs:
+ logging.info("Packages that ship the affected binaries:")
for pkg in pkgs.values():
logging.info(" Pkg: %s, binaries: %s" % (pkg.name, pkg.procs))
diff --git a/whatmaps/debiandistro.py b/whatmaps/debiandistro.py
index 3a3bf16..2a095d1 100644
--- a/whatmaps/debiandistro.py
+++ b/whatmaps/debiandistro.py
@@ -47,9 +47,10 @@ class DebianDistro(Distro):
'dovecot-pop3d': [ 'dovecot' ],
'exim4-daemon-light': [ 'exim4' ],
'exim4-daemon-heavy': [ 'exim4' ],
- 'qemu-system-x86_64': [ 'libvirt-guests' ],
+ 'libvirt-daemon': [ 'libvirtd' ],
'openjdk-6-jre-headless': ['jenkins', 'tomcat7'],
'openjdk-7-jre-headless': ['jenkins', 'tomcat7'],
+ 'qemu-system-x86_64': [ 'libvirt-guests' ],
}
# Per package blacklist
diff --git a/whatmaps/systemd.py b/whatmaps/systemd.py
index 3407128..ef15a26 100644
--- a/whatmaps/systemd.py
+++ b/whatmaps/systemd.py
@@ -1,6 +1,6 @@
# vim: set fileencoding=utf-8 :
#
-# (C) 2014 Guido Günther <agx@sigxcpu.org>
+# (C) 2014,2015 Guido Günther <agx@sigxcpu.org>
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
@@ -44,4 +44,4 @@ class Systemd(object):
elif parts[1].endswith('.service'):
return parts[1]
else:
- raise ValueError("Can't parse service name from\n%s" % output)
+ raise ValueError("Can't parse service name from: (%s %s)" % (parts[0], parts[1]))