summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-09-24 13:25:36 +0200
committerGuido Günther <agx@sigxcpu.org>2010-09-25 15:47:57 +0200
commit1f3b0f8a640d948849181fe07f4a5fe4431e95b9 (patch)
tree780abd32a26d199ad7383d321b63f62f9c31fa90 /setup.py
parent050d3b21bf30bbd6f60d4819600c7d1550e4e5fd (diff)
Fixups for Lenny
Cope with older apt_pkg and don't substitute disto_id, distro_codename due to the lack of the lsb_release python module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 5 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index f79ef8e..cef1d55 100644
--- a/setup.py
+++ b/setup.py
@@ -3,18 +3,11 @@
from distutils.core import setup
-data_files = []
-
-try:
- import lsb_release
- if lsb_release.get_distro_information()['ID'] in [ 'Debian' ]:
- data_files = [('../etc/apt/apt.conf.d/',
- ['apt/50whatmaps_apt']),
- ('../etc/apt/apt.conf.d/',
- ['apt/20services']),
- ]
-except ImportError:
- pass
+data_files = [('../etc/apt/apt.conf.d/',
+ ['apt/50whatmaps_apt']),
+ ('../etc/apt/apt.conf.d/',
+ ['apt/20services']),
+ ]
setup(name = "whatmaps",
author = 'Guido Günther',