summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-04-18 11:52:52 +0200
committerGuido Günther <agx@sigxcpu.org>2014-04-18 13:45:02 +0200
commit0e8224cf4b6d2a5ef6e8c7165dc6143db3cbc482 (patch)
tree5b090f39b251878aa32ea8f55ec2686bb7c9adb5 /setup.py
parenta785b391030e9a8936ae61c2de890082311a8c42 (diff)
Use entrypoint
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1da9283..46b0d81 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,10 @@ setup(name = "whatmaps",
author = 'Guido Günther',
author_email = 'agx@sigxcpu.org',
data_files = data_files,
- scripts = [ 'whatmaps' ],
+ packages = ['whatmaps'],
+ entry_points = {
+ 'console_scripts': [ 'whatmaps = whatmaps.command:run' ],
+ },
)
# vim:et:ts=4:sw=4:et:sts=4:ai:set list listchars=tab\:»·,trail\:·: