aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-09-03 21:50:42 +0200
committerGuido Günther <agx@sigxcpu.org>2010-09-24 17:43:26 +0200
commite4e112bde13d79d4648b7f366c726a64577fd83b (patch)
treeac60aff2bf22280b64859bc52037476ba407d4a6 /setup.py
parent55abf2002d7f51aeafe11070fe47b9da0dcfbf1c (diff)
Hook into apt pipeline
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 16 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ef0b612..f79ef8e 100644
--- a/setup.py
+++ b/setup.py
@@ -3,9 +3,24 @@
from distutils.core import setup
+data_files = []
+
+try:
+ import lsb_release
+ if lsb_release.get_distro_information()['ID'] in [ 'Debian' ]:
+ data_files = [('../etc/apt/apt.conf.d/',
+ ['apt/50whatmaps_apt']),
+ ('../etc/apt/apt.conf.d/',
+ ['apt/20services']),
+ ]
+except ImportError:
+ pass
+
setup(name = "whatmaps",
author = 'Guido Günther',
author_email = 'agx@sigxcpu.org',
- scripts = [ 'whatmaps' ]
+ data_files = data_files,
+ scripts = [ 'whatmaps' ],
)
+# vim:et:ts=4:sw=4:et:sts=4:ai:set list listchars=tab\:»·,trail\:·: