summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAge
* Run ./autogen.sh conditionallyHEADdebian/sidGuido Günther2017-08-08
| | | | | | | This helps crossbuild but still allows us to build git snapshots. Based on a patch from Helmut Grohne Closes: #871475
* Document changes and release 1.2.0-1debian/1.2.0-1Guido Günther2016-07-21
|
* Use https URL for VCS-GitGuido Günther2016-07-21
|
* Merge tag 'v1.2.0' into debian/sidGuido Günther2016-07-20
|\ | | | | | | Release network-manager-iodine 1.2.0
| * release: bump version to 1.2.0v1.2.0Lubomir Rintel2016-04-22
| | | | | | | | NetworkManager-1.2 is now released; good time for a plugin release as well.
| * appdata: add AppStream metadataLubomir Rintel2016-04-22
| | | | | | | | | | This will ensure the Iodine NetworkManager plugin will be easily installable from the app stores such as GNOME Software.
| * properties: move the domain beneath a GtkGrid similar to one belowLubomir Rintel2016-04-22
| | | | | | | | | | | | | | | | | | ...instead of a GtkTable. This is nothing too impressive, but looks better when strechted on screenshot of a size that AppStream finds acceptable. The third column of the grids could be moved away altogether if the password flag widget was used; but for now this works well.
| * build: don't include the full path to a plugin by defaultLubomir Rintel2016-04-22
| | | | | | | | | | Makes packagers a bit less sad. We always keep the full paths in /etc for compatibility.
| * Update doap informationGuido Günther2016-03-13
| |
| * Point to gnome tarballsGuido Günther2016-03-13
| |
* | Document changes and release 1.1.0-1debian/1.1.0-1Guido Günther2016-03-13
| |
* | Make override_dh_makeshlibs multiarch awareGuido Günther2016-03-13
| |
* | Bump standards versionGuido Günther2016-03-13
| | | | | | | | no source changes neede
* | Use secure URL for gitwebGuido Günther2016-03-13
| |
* | Revert accidental change on debian branchGuido Günther2016-03-13
| |
* | Update dependencies for NM 1.1Guido Günther2016-03-13
| |
* | Merge tag 'v1.1.0' into debian/sidGuido Günther2016-03-13
|\ \ | |/ | | | | Release network-manager-iodine 1.1.0
| * Merge branch 'nm-1.1'v1.1.0Guido Günther2016-03-13
| |\
| | * build: install the service file into /usr/lib tooLubomir Rintel2015-10-13
| | | | | | | | | | | | | | | | | | | | | It's not really a configuration file and should not be installed into /etc. See file-hierarchy(7). We need the old location for the old property plugin though.
| | * build: allow build without libnm-glibLubomir Rintel2015-10-13
| | |
| | * auth-dialog: port to libnmLubomir Rintel2015-10-13
| | |
| | * service: port to libnmLubomir Rintel2015-10-13
| | |
| | * properties: rename the classes to be more libnm-ishLubomir Rintel2015-09-01
| | | | | | | | | | | | No functional change.
| | * properties: use the NM error types & quarksLubomir Rintel2015-09-01
| | |
| | * properties: port to libnmLubomir Rintel2015-09-01
| | |
| | * build: check for libnm & libnmaLubomir Rintel2015-09-01
| | |
| | * build: split the plugin into two halvesLubomir Rintel2015-09-01
| | | | | | | | | | | | They're both the same now. We'll later port the new one to libnm.
| | * build: bump version to 1.1.0Lubomir Rintel2015-09-01
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Adopt the same naming scheme as NetworkManager and other VPN plugins use: 1.<odd>.0 = development snapshot of NetworkManager 1.<odd+1>.0 major release 1.<even>.<odd> = development snapshot of NetworkManager 1.<even>.<odd+1> stable release 1.<even>.<even> = a stable release NetworkManager 1.2 (which is currently versioned as 1.1.0) is going to bring some new ABI while still supporting the old one. There's new VPN service and UI plugin APIs in libnm. There's one difficulty though -- the connection editor 1.2 will be linked against libnm and a new libnma library it will provide (as opposed to libnm-glib and libnm-gtk), thus will be incapable of loading of property plugins that are linked with the old libraries (due to glib type system limitations). However, we must not break support for other connection editors (GNOME control center, KDE, older versions of nm-connection-editor, etc.) therefore we need to build two versions of the property plugin. NetworkManager 1.2's libnm will provide a shim that makes it easy. For these reasons, the plugin will require building with NetworkManager >= 1.1.0 (it will still happily work with older connection editors or would even talk to older versions of NM if one would install one). Let's make that clear in the version number.
| | * build: only check for libnm-gtk when we're building GNOME supportLubomir Rintel2015-09-01
| | |
| * | Update Catalan translationJordi Mas2016-01-12
| | |
| * | Updated German translationMario Blättermann2016-01-01
| | |
| * | Added Portuguese translationPedro Albuquerque2015-11-08
| |/
| * Updated Polish translationPiotr Drąg2015-08-30
| |
| * Added Swedish translationJosef Andersson2015-07-19
| |
| * all: trivial: fix indentingJiří Klimeš2015-03-25
| | | | | | | | No functional change.
| * all: fix *_IS_*_CLASS(klass) macrosJiří Klimeš2015-03-25
| | | | | | | | The argument is 'klass', not 'obj'.
| * properties: use a real GError domain instead of 0Jiří Klimeš2015-03-25
| | | | | | | | GLib complains about domain being 0.
| * Split out nm-iodine-service-defines.hDan Winship2015-03-25
| | | | | | | | | | Split nm-iodine-service-defines.h out of nm-iodine-service.h, so that the -defines.h file has no dependency on either libnm or libnm-glib.
| * all: use nm_connection_get_setting_*()Dan Winship2015-03-25
| | | | | | | | | | The code was still using nm_connection_get_setting(). Use the typesafe setting-specific versions instead.
| * Rename NMIODINEPlugin to NMIodinePluginDan Winship2015-03-24
| | | | | | | | Because, seriously.
| * build: remove some unnecessary stuffDan Winship2015-03-24
| | | | | | | | | | | | | | | | | | | | | | | | | | | | PKG_CHECK_MODULES() automatically AC_SUBST()s the variables it creates, so we don't need to do it ourselves. Drop unnecessary explicit checks for gthread and dbus-glib. Remove unused INCLUDES= lines from Makefiles. Remove stray GConf references. Remove "#define NM_VPN_API_SUBJECT_TO_CHANGE", since that define has had no effect since before NM 0.7.
| * Added Bosnian translationSamir Ribic2015-03-14
| |
| * Added Turkish translationNecdet Yücel2014-12-16
| |
* | Bump build-dep on libnm-gtk-devGuido Günther2014-12-03
| | | | | | | | | | Closes: #771821 Thanks: Logan Rosen
* | Adjust bug download URL to offical download.gnome.orgGuido Günther2014-10-12
| |
* | Document changes and release 0.0.5-1debian/0.0.5-1Guido Günther2014-10-12
| |
* | Bump standards version to 0.9.5Guido Günther2014-10-12
| |
* | Build-depend on libnm-gtk and libsecretsGuido Günther2014-10-12
| |
* | Drop 0001-Disabe-gnome-keyring-deprecation-warnings.patchGuido Günther2014-10-12
| | | | | | | | Fixed upstream
* | Merge tag 'v0.0.5' into debian/sidGuido Günther2014-10-12
|\ \ | |/ | | | | network-manager-iodine 0.0.5