aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-11-06 18:29:19 +0100
committerGuido Günther <agx@sigxcpu.org>2011-11-06 18:29:19 +0100
commit0458ba8b2ea232188a9aa759c95a495412b9b403 (patch)
treea905dd36f664dff66ee1c9479c210256c6269a0c /debian/rules
parent043b1cb3a4ef51fecafdb9558b183b62425f4d72 (diff)
Move doc generation to separate Makefile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules42
1 files changed, 5 insertions, 37 deletions
diff --git a/debian/rules b/debian/rules
index c570daa2..d09ea5a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,16 +6,6 @@ DEB_PYTHON_CLEAN_ARGS = --all
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
-COMMANDS = git-buildpackage \
- git-import-dsc \
- git-import-dscs \
- git-import-orig \
- git-dch \
- gbp-pull \
- gbp-clone \
- gbp-pq \
- gbp-create-remote-repo
-
EXAMPLE_SCRIPTS=\
gbp-add-patch \
gbp-cowbuilder-sid \
@@ -25,29 +15,9 @@ EXAMPLE_SCRIPTS=\
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
-SGML_MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
-POD_MANPAGES=docs/git-pbuilder.1
-MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
-MANUAL=docs/manual-html
PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
GBP_VERSION=gbp/gbp_version.py
-VERSION_ENT=docs/version.ent
-
-docs/%.1: docs/man.%.sgml
- docbook2man -o docs/ $<
-
-docs/manual.sgml: docs/version.ent
-
-$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
- docbook-2-html -s local $<
- cp /usr/share/gtk-doc/data/*.png $(MANUAL)
-
-docs/git-pbuilder.1: bin/git-pbuilder
- pod2man $< $@
-
-apidocs:
- epydoc --config=setup.cfg
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
pychecker:
@@ -64,17 +34,15 @@ endif
$(GBP_VERSION): debian/changelog
echo 'gbp_version="$(DEB_VERSION)"' > $(GBP_VERSION)
-$(VERSION_ENT): debian/changelog
- echo '<!ENTITY gbp-version "$(DEB_VERSION)">' > $(VERSION_ENT)
-
-build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(GBP_VERSION) checks apidocs
+build/git-buildpackage:: $(GBP_VERSION) checks
+ epydoc --config=setup.cfg
+ make -C docs/
binary-post-install/git-buildpackage::
dh_bash-completion
clean::
- -rm git_*.py gbp_*.py gbp/gbp_version.py links_stamp
- -rm docs/*.1 docs/manpage.* $(VERSION_ENT) git-pbuilder.1
- -rm -r docs/manual-html/
+ make -C docs/ clean
+ -rm gbp/gbp_version.py
.PHONY: checks