aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-07-25 11:36:26 +0200
committerGuido Günther <agx@sigxcpu.org>2011-07-25 11:37:00 +0200
commit305e8715482dc1660c981f523601b01a0145e7cc (patch)
treec23741004f70e6591f9f86c9593dfa1c7075cd79 /debian/rules
parentc8217fba315441d1068f0999ddb293f0329f9092 (diff)
Reenable pychecker checks
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index e459e86b..3fe700c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -52,8 +52,11 @@ links_stamp:
done
touch links_stamp
+pychecker:
+ PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q git*.py gbp*.py
-checks: links_stamp
+
+checks: links_stamp pychecker
export GIT_AUTHOR_NAME="Gbp Tests"; \
export GIT_AUTHOR_EMAIL=tests@example.com; \
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
@@ -61,10 +64,6 @@ checks: links_stamp
nosetests --exe --with-doctest
endif
-%.py: %
- ln -s $< $@
- PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q $<
-
$(GBP_VERSION): debian/changelog
echo 'gbp_version="$(DEB_VERSION)"' > $(GBP_VERSION)