aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-09-12 08:03:39 +0200
committerGuido Günther <agx@sigxcpu.org>2016-09-12 09:00:12 +0200
commit3ded91b33ad1f756ed9e7c798528aeace532fdf3 (patch)
treee3de240e25184022d36f1bdbf8210852897a07da /debian/rules
parent9fcd6b1595c08363d09760c48fc24ece61c5a97f (diff)
Move doc generation and test invocation to separate Makefile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 3 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 405bb88d..00702d4d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,28 +14,19 @@ ZSH_COMPDIR = /usr/share/zsh/vendor-completions/
PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
%:
- dh $@ --with python2
+ dh $@ --with python2 --buildsystem=python_distutils
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
dh_auto_test
- export GIT_AUTHOR_NAME="Gbp Tests"; \
- export GIT_AUTHOR_EMAIL=tests@example.com; \
- export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
- export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
- PYTHONPATH=. \
- python setup.py nosetests --with-xcoverage
-
- PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q \
- gbp gbp.scripts gbp.git gbp.deb
+ make
else
@echo "Checks disabled via DEB_BUILD_OPTIONS"
endif
override_dh_auto_build:
dh_auto_build
- epydoc -v --config=setup.cfg
- make -C docs/
+ make apidocs docs
override_dh_auto_install:
dh_auto_install