aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-08-12 18:37:06 +0200
committerGuido Günther <agx@sigxcpu.org>2010-08-12 18:37:44 +0200
commit76b16df48a351cf7b8a895bdbcd09e2b8b873b08 (patch)
treef946cffd8af1d75556b8ee3fb0f9e390965a84ec /debian/rules
parent61e0c3c9f9dda6f448b0a80175cbf54fdc966d94 (diff)
Build and install git-pbuilder manpage
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 8a1d813a..b81ad946 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,9 @@ EXAMPLE_SCRIPTS=\
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
-MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS) gbp-pq)
+SGML_MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS) gbp-pq)
+POD_MANPAGES=docs/git-pbuilder.1
+MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
@@ -39,6 +41,9 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
docbook-2-html -s local $<
cp /usr/share/gtk-doc/data/*.png $(MANUAL)
+docs/git-pbuilder.1: git-pbuilder
+ pod2man $< $@
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
checks: $(PYCHECKS)
nosetests --with-doctest