aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2013-10-30 17:25:22 -0300
committerGuido Günther <agx@sigxcpu.org>2013-10-31 19:33:27 +0100
commitbabbc5e7721da27d92c519bfe1cf7829066cb2fe (patch)
tree900ecbb1ccbcaf5fac9c073da02ea9a126a2cdd7 /debian/rules
parent0c0086b917f9dd9fdb53f6a17ba67811128568cc (diff)
Add zsh completion
Closes; #717002
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2c40befc..a80bd520 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,8 @@ EXAMPLE_SCRIPTS=\
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
+ZSH_COMPDIR = /usr/share/zsh/vendor-completions/
+
PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
%:
@@ -38,6 +40,9 @@ override_dh_auto_build:
override_dh_auto_install:
dh_auto_install
dh_bash-completion
+ mkdir -p debian/git-buildpackage/$(ZSH_COMPDIR)
+ install -m644 debian/git-buildpackage.zsh-completion \
+ debian/git-buildpackage/$(ZSH_COMPDIR)/_gbp
override_dh_auto_clean:
dh_auto_clean