aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-12-27 23:43:05 +0100
committerGuido Günther <agx@sigxcpu.org>2010-12-28 00:15:13 +0100
commitbd2ac3aa3639defc1ad6b9f322e112d1a77b7eef (patch)
tree3f84c97f08ca9e570a87c67c5c04ba41645b1b6a /debian/rules
parent63d96249e8a19af0b57fe54fba612ac0cb98a01f (diff)
Enable pychecker warnings
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 4e9a43e3..ab675e66 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,7 +29,7 @@ POD_MANPAGES=docs/git-pbuilder.1
MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
-PYCHECK_LEVEL=Error
+PYCHECKER_ARGS=--maxlines=300 -boptparse --no-override --no-shadowbuiltin
GBP_VERSION=gbp/gbp_version.py
VERSION_ENT=docs/version.ent
@@ -52,7 +52,7 @@ endif
%.py: %
ln -s $< $@
- PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
+ PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q $<
$(GBP_VERSION): debian/changelog
echo 'gbp_version="$(DEB_VERSION)"' > $(GBP_VERSION)