aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-08-02 01:32:37 -0300
committerGuido Günther <agx@sigxcpu.org>2017-08-02 13:10:57 -0300
commitdf7f0289851ac6c9cb106e5dbd62dc3fbbf113aa (patch)
tree164072b87f6633a83b2d8dd682ce72a84abb0092 /debian/rules
parentb40cb2584ee63cdc793d10432362fdb32034e604 (diff)
Switch Debian packaging to python3
For now we disable epydoc since it isn't available for python3. We also drop dh_auto_test to not run the test suite twice since pybuild would run it as well. Closes: #810854
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 1be5dbcc..4fd43974 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,11 +14,10 @@ ZSH_COMPDIR = /usr/share/zsh/vendor-completions/
PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
%:
- dh $@ --with python2 --buildsystem=python_distutils
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- dh_auto_test
make
else
@echo "Checks disabled via DEB_BUILD_OPTIONS"
@@ -26,7 +25,7 @@ endif
override_dh_auto_build:
dh_auto_build
- make apidocs docs
+ make docs
override_dh_auto_install:
dh_auto_install
@@ -34,7 +33,7 @@ override_dh_auto_install:
mkdir -p debian/git-buildpackage/$(ZSH_COMPDIR)
install -m644 debian/git-buildpackage.zsh-completion \
debian/git-buildpackage/$(ZSH_COMPDIR)/_gbp
- chmod a+x debian/tmp/usr/lib/python2.?/dist-packages/gbp/scripts/supercommand.py
+ chmod a+x debian/tmp/usr/lib/python3.?/dist-packages/gbp/scripts/supercommand.py
override_dh_auto_clean:
dh_auto_clean