aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-10-30 20:03:33 +0100
committerGuido Günther <agx@sigxcpu.org>2011-11-01 18:12:48 +0100
commite28ea0740a7b4eb2ef4c1bd3079d77a40c6072b8 (patch)
tree779145e71a996c471a1d1a6b1acde1bc90deecc4 /debian/rules
parentabf90abcba15beb51196cf503f35695acdcd91c1 (diff)
Get rid of the symlink
by moving the commands to gbp/scripts/
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 6 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 735cb452..b8fccabe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,30 +43,24 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
cp /usr/share/gtk-doc/data/*.png $(MANUAL)
-docs/git-pbuilder.1: git-pbuilder
+docs/git-pbuilder.1: bin/git-pbuilder
pod2man $< $@
-links_stamp:
- for c in $(COMMANDS); do \
- ln -s $$c $$(echo $$c | sed -e 's,-,_,g').py; \
- done
- touch links_stamp
-
-apidocs: links_stamp
+apidocs:
epydoc -v -n git-buildpackage --no-sourcecode -o docs/apidocs/ \
--url=https://honk.sigxcpu.org/piki/projects/git-buildpackage/ \
- --fail-on-docstring-warning \
- gbp*.py git*.py gbp/ tests/test_Git*.py
+ --fail-on-docstring-warning gbp/ tests/test_Git*.py
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
pychecker:
- PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q git*.py gbp*.py
+ PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q gbp
-checks: links_stamp pychecker
+checks: pychecker
export GIT_AUTHOR_NAME="Gbp Tests"; \
export GIT_AUTHOR_EMAIL=tests@example.com; \
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
+ export PYTHONPATH=$$(pwd); \
nosetests --exe --with-doctest --with-coverage --cover-package=gbp
endif