aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-01-10 16:09:05 +0100
committerGuido Günther <agx@sigxcpu.org>2011-01-11 07:47:13 +0100
commit03f3d75d43458978ecc375f7e16cfc8f35b5ae99 (patch)
tree81e7ec81df5ff6a123e5f856d8c5e738c485cdd2 /debian
parent05d9ecb7e4eaf6cfc8942c5c47b6f9dde2e99459 (diff)
Make gbp-create-remote-repo a first class citizen
Add manpage, move into path, add bash completion
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/git-buildpackage.bash-completion11
-rwxr-xr-xdebian/rules8
3 files changed, 16 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 8fcd5c5c..b08a2efe 100644
--- a/debian/control
+++ b/debian/control
@@ -26,3 +26,4 @@ Description: Suite to help with Debian packages in Git repositories
* git-dch: generate Debian changelog entries from Git commit messages
* gbp-{pull,clone}: clone and pull from remote repos
* gbp-pq: manage debian/patches easily
+ * gbp-create-remote-repo: create remote repositories
diff --git a/debian/git-buildpackage.bash-completion b/debian/git-buildpackage.bash-completion
index 1b855040..fda633e9 100644
--- a/debian/git-buildpackage.bash-completion
+++ b/debian/git-buildpackage.bash-completion
@@ -155,3 +155,14 @@ _gbp_clone ()
_gbp_comp "$options" "$branch_opts" "$tag_opts" "$tristate_opts"
}
[ "${have:-}" ] && complete -F _gbp_clone -o default gbp-clone
+
+have gbp-create-remote-repo &&
+_gbp_create_remote_repo ()
+{
+ local options=$(_gbp_options gbp-create-remote-repo)
+ local branch_opts="--debian-branch\= --upstream-branch\="
+ local tristate_opts="--color\="
+
+ _gbp_comp "$options" "$branch_opts" "" "$tristate_opts"
+}
+[ "${have:-}" ] && complete -F _gbp_create_remote_repo -o default gbp-create-remote-repo
diff --git a/debian/rules b/debian/rules
index ab675e66..63c60c46 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,18 +13,18 @@ COMMANDS = git-buildpackage \
git-dch \
gbp-pull \
gbp-clone \
- gbp-pq
+ gbp-pq \
+ gbp-create-remote-repo
EXAMPLE_SCRIPTS=\
gbp-add-patch \
gbp-cowbuilder-sid \
gbp-pbuilder \
- gbp-posttag-push \
- gbp-create-remote-repo
+ gbp-posttag-push
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
-SGML_MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS) gbp-pq)
+SGML_MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
POD_MANPAGES=docs/git-pbuilder.1
MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
MANUAL=docs/manual-html