aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-03-11 18:08:58 +0100
committerGuido Günther <agx@sigxcpu.org>2011-03-12 23:12:22 +0100
commit40f4709668425b03b9f59c28176547c313957715 (patch)
tree166980187712abd948005dce6b348899956a0a8b /debian
parent9bb73b46d2f215dc70482e55311a64debeca4d6e (diff)
gbp-pq: Allow to specify subdirs for patches
via the "Gbp-Pq-Tag: <subdir>" directive in the patch header. This also gets rid sed callouts. Add "apply" action to apply single patches
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog17
-rw-r--r--debian/git-buildpackage.bash-completion3
2 files changed, 18 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 00645823..9a4cee1c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
+git-buildpackage (0.5.20~1.gbp194f43) UNRELEASED; urgency=low
+
+ ** SNAPSHOT build @194f43948c2d5789d28dd5ba9167014199220182 **
+
+ * [a618bdc] Make the desktop notification transient
+ so they timeout and don't clutter the notification area.
+ * [3b0f296] Add script to ignore .pc and tell dpkg-source unpatch the
+ source. See #591858.
+ * [258743a] is_fast_forward: make sure git interprets arguments as revisions
+ so git prints a clearer error message on configuration errors in
+ .git/config
+ * [194f439] gbp-pq: Allow to specify subdirs for patches via the
+ "Gbp-Pq-Tag: <subdir>" directive in the patch header. This also gets rid
+ sed callouts. Add "apply" action to apply single patches
+
+ -- Guido Günther <agx@sigxcpu.org> Sat, 12 Mar 2011 21:40:58 +0100
+
git-buildpackage (0.5.19) unstable; urgency=low
[ Jonathan Nieder ]
diff --git a/debian/git-buildpackage.bash-completion b/debian/git-buildpackage.bash-completion
index fda633e9..0f8c9d5e 100644
--- a/debian/git-buildpackage.bash-completion
+++ b/debian/git-buildpackage.bash-completion
@@ -124,10 +124,9 @@ have gbp-pq &&
_gbp_pq ()
{
local options=$(_gbp_options gbp-pq)
- options="$options export import rebase drop"
+ options="$options export import rebase drop apply"
local tristate_opts="--color\="
- _gbp_comp "$options"
_gbp_comp "$options" "" "" "$tristate_opts"
}
[ "${have:-}" ] && complete -F _gbp_pq -o default gbp-pq