aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2007-10-19 09:22:17 +0200
committerGuido Guenther <agx@sigxcpu.org>2007-10-19 09:22:17 +0200
commit53d0b13794018f88dcd2df017667e173bb333abf (patch)
treeeae05ca7a450536da845d8403c67630233684cea /debian
parent44a34275141b0646cadfdac38f4c34bbaed1b68e (diff)
add version number to docs and a tools
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules14
1 files changed, 12 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 1dc87692..80b8218e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,10 +12,14 @@ MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
+GBP_VERSION=gbp/gbp_version.py
+VERSION_ENT=docs/version.ent
docs/%.1: docs/man.%.sgml
docbook2man -o docs/ $<
+docs/manual.sgml: docs/version.ent
+
$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
docbook-2-html -s local $<
@@ -23,10 +27,16 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
ln -s $< $@
PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
-build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(PYCHECKS)
+$(GBP_VERSION): debian/changelog
+ echo 'gbp_version="$(DEB_VERSION)"' > $(GBP_VERSION)
+
+$(VERSION_ENT): debian/changelog
+ echo '<!ENTITY gbp-version "$(DEB_VERSION)">' > $(VERSION_ENT)
+
+build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(GBP_VERSION) $(PYCHECKS)
clean::
-rm git-*.py
- -rm docs/*.1 docs/manpage.*
+ -rm docs/*.1 docs/manpage.* docs/$(VERSION_ENT)
-rm -r docs/manual-html/