aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-10-23 17:18:06 +0200
committerGuido Günther <agx@sigxcpu.org>2015-10-23 19:34:34 +0200
commit0bb2064be033fe04477a74e8c3d88891d9386cb5 (patch)
tree262df9f05bb99694a805530149a5a29e2226aba7 /setup.py
parent3410331cc36e6d5719f3a697a57d5fcd14193f6a (diff)
setup.py: decode string
to make Python3 happy
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 355b1487..89c83d32 100644
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,7 @@ def fetch_version():
try:
popen = subprocess.Popen('dpkg-parsechangelog', stdout=subprocess.PIPE)
out, ret = popen.communicate()
- for line in out.split('\n'):
+ for line in out.decode('utf-8').split('\n'):
if line.startswith('Version:'):
version = line.split(' ')[1].strip()
break