aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-01-08 19:35:34 +0100
committerGuido Günther <agx@sigxcpu.org>2013-06-18 23:55:05 +0200
commit12dce5f8469d5a6508df518134cae133d8da6efb (patch)
treec6c7d8b4507ea5a44b76bbd4566f1b71dfc3c8ba /setup.py
parent75cbd9af3f63adbbaaa04187e749583be89a17e2 (diff)
Add wrapper for all gbp commands
So like git you can now use gbp <command> instead of git-<command> or gbp-<command>. The manpages and docs aren't adjusted yet.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7fe71b7c..fe7109a1 100644
--- a/setup.py
+++ b/setup.py
@@ -58,5 +58,8 @@ setup(name = "gbp",
packages = find_packages(exclude=['tests', 'tests.*']),
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
setup_requires=['nose>=0.11.1', 'coverage>=2.85', 'nosexcover>=1.0.7'] if \
- os.getenv('WITHOUT_NOSETESTS') is None else []
+ os.getenv('WITHOUT_NOSETESTS') is None else [],
+ entry_points = {
+ 'console_scripts': [ 'gbp = gbp.scripts.command:gbp_command' ],
+ },
)