aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2024-01-10 11:00:57 +0100
committerGuido Günther <agx@sigxcpu.org>2024-01-10 11:49:19 +0100
commit2f47ec4cb19cec2f17e66ff463a7000583d2ee25 (patch)
tree67e160aacbc102c9bb6a1c42e5993ace01759d04 /setup.py
parent75cda5279eef3b158aae399d1086dde2975446be (diff)
setup: Move most options to setup.cfg
We can move everything that doesn't depend on running a script or evaluating environment variables.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py33
1 files changed, 2 insertions, 31 deletions
diff --git a/setup.py b/setup.py
index 4629bbd1..09512274 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/python3
# vim: set fileencoding=utf-8 :
-# Copyright (C) 2006-2011 Guido Günther <agx@sigxcpu.org>
+# Copyright (C) 2006-2024 Guido Günther <agx@sigxcpu.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
import os
import re
-from setuptools import setup, find_packages
+from setuptools import setup
VERSION_PY_PATH = 'gbp/version.py'
@@ -63,11 +63,6 @@ def parse_and_fetch_version():
return version
-def readme():
- with open('README.md') as file:
- return file.read()
-
-
def setup_requires():
if os.getenv('WITHOUT_NOSETESTS'):
return []
@@ -77,29 +72,5 @@ def setup_requires():
setup(name="gbp",
version=parse_and_fetch_version(),
- author=u'Guido Günther',
- author_email='agx@sigxcpu.org',
- url='https://honk.sigxcpu.org/piki/projects/git-buildpackage/',
- description='Suite to help with Debian packages in Git repositories',
- license='GPLv2+',
- long_description=readme(),
- classifiers=[
- 'Environment :: Console',
- 'Programming Language :: Python :: 3',
- 'Topic :: Software Development :: Version Control',
- 'Operating System :: POSIX :: Linux',
- ],
- scripts=['bin/git-pbuilder',
- 'bin/gbp-builder-mock'],
- packages=find_packages(exclude=['tests', 'tests.*']),
- data_files=[("share/git-buildpackage/", ["gbp.conf"]), ],
- requires=['dateutil'],
- install_requires=[
- 'python-dateutil',
- ],
setup_requires=setup_requires(),
- python_requires='>=3.5',
- entry_points={
- 'console_scripts': ['gbp=gbp.scripts.supercommand:supercommand'],
- },
)