aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorQuanah Gibson-Mount <quanah@symas.com>2021-05-24 13:26:28 -0400
committerGuido Günther <agx@sigxcpu.org>2021-05-28 11:28:04 +0200
commit3adf602f2f311c616f2b98751eb91185a89a3379 (patch)
tree83080cfaca62c50d84c5befcd37020ac8dc246bf /setup.py
parent3a6b6299e69cf563c518dddacd19c32050e19b9c (diff)
setup.py: Explicitly open the changelog file as utf-8
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0cc31b9e..4629bbd1 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ VERSION_PY_PATH = 'gbp/version.py'
def _parse_changelog():
"""Get version from debian changelog and write it to gbp/version.py"""
- with open("debian/changelog") as f:
+ with open("debian/changelog", encoding="utf-8") as f:
line = f.readline()
# Parse version from changelog without external tooling so it can work