aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-11-16 08:57:27 +0100
committerGuido Günther <agx@sigxcpu.org>2015-11-16 08:57:27 +0100
commitbfe32f19e7a2a24b93b36467772254583c34b6ff (patch)
tree73691e068c34f3348a1dcf0274c45313627b9929 /setup.py
parent82a847df8a04f598dafa31af46b9493255a6f033 (diff)
buildpackage-rpm: add support for mock chroot builder
Try: gbp buildpackage-rpm --git-mock --git-dist=epel-6 Results will be under ../rpmbuild/results/ This is very heavily based on a patch from Tzafrir Cohen.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 89c83d32..bbc0ba8a 100644
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,8 @@ setup(name = "gbp",
'Topic :: Software Development :: Version Control :: Git',
'Operating System :: POSIX :: Linux',
],
- scripts = ['bin/git-pbuilder'],
+ scripts = ['bin/git-pbuilder',
+ 'bin/gbp-builder-mock'],
packages = find_packages(exclude=['tests', 'tests.*']),
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
requires = ["six"],