aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorKen Dreyer <kdreyer@redhat.com>2017-07-03 16:09:54 -0600
committerGuido Günther <agx@sigxcpu.org>2017-07-04 07:54:50 +0200
commitd05dfea469e71f4fa13619f69639b83a105cea34 (patch)
tree5bdd45bf9a762fc0b62bb0da19ac192c612cf2bd /setup.py
parentdf98740ee0ee4cf8f969c54994b94dad61cca9d7 (diff)
setup.py: require dateutil
We import dateutil, but we only declare this dependency within the debian packaging and RPM packaging. Add the dependency to Python's setuptools packaging as well. This allows git-buildpackage to install seamlessly within a Python virtualenv. Signed-off-by: Guido Günther <agx@sigxcpu.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 385d2f4c..b6d6c3d0 100755
--- a/setup.py
+++ b/setup.py
@@ -73,7 +73,7 @@ setup(name="gbp",
'bin/gbp-builder-mock'],
packages=find_packages(exclude=['tests', 'tests.*']),
data_files=[("share/git-buildpackage/", ["gbp.conf"]), ],
- requires=["six"],
+ requires=["six", "python-dateutil"],
setup_requires=setup_requires(),
entry_points={
'console_scripts': ['gbp=gbp.scripts.supercommand:supercommand'],