aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>2013-03-06 11:11:56 +0200
committerGuido Günther <agx@sigxcpu.org>2013-03-22 21:01:36 +0100
commitdcf746752a942e6300b1534c8119c2da84b26d8f (patch)
tree92de052668cb381f76df03c349e1615b2d9f5691 /setup.py
parent7709f217c05f22d6c06f61cbc83b78790e2e1cbc (diff)
setup: possibility to skip nosetest requirements
Makes it possible to not require test requirements by defining WITHOUT_NOSETESTS environment variable when running setup. Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4042eb40..d43ca6b0 100644
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,7 @@
import subprocess
from setuptools import setup, find_packages
+import os
def fetch_version():
@@ -40,7 +41,6 @@ def fetch_version():
return version
-
setup(name = "gbp",
version = fetch_version(),
author = u'Guido Günther',
@@ -57,5 +57,6 @@ setup(name = "gbp",
'bin/git-pbuilder'],
packages = find_packages(exclude=['tests', 'tests.*']),
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
- setup_requires=['nose>=0.11.1', 'coverage>=2.85'],
+ setup_requires=['nose>=0.11.1', 'coverage>=2.85'] if \
+ os.getenv('WITHOUT_NOSETESTS') is None else []
)