aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-03-05 20:01:08 +0100
committerGuido Günther <agx@sigxcpu.org>2014-03-05 20:17:34 +0100
commitbde2ccae927c98caf9b9428f59a4c86aea863139 (patch)
treeef842fe77f29b151b805bfd03a8538cc32d8b312 /configure.ac
parent54f96f2de1d96cce42a21e7062b0842772e77a2e (diff)
Don't open code GObject Introspetion
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 12 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 1e744c4..ee6e38f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,31 +46,7 @@ PKG_CHECK_MODULES(GIO2, gio-2.0 >= $GLIB2_REQUIRED)
PKG_CHECK_MODULES(LIBXML2, libxml-2.0 >= $LIBXML2_REQUIRED)
PKG_CHECK_MODULES(LIBSOUP, libsoup-2.4 >= $LIBSOUP_REQUIRED)
-AC_ARG_ENABLE([introspection],
- AS_HELP_STRING([--enable-introspection], [enable GObject introspection]),
- [], [enable_introspection=check])
-
-if test "x$enable_introspection" != "xno" ; then
- PKG_CHECK_MODULES([GOBJECT_INTROSPECTION],
- [gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED],
- [enable_introspection=yes],
- [
- if test "x$enable_introspection" = "xcheck"; then
- enable_introspection=no
- else
- AC_MSG_ERROR([gobject-introspection is not available])
- fi
- ])
- if test "x$enable_introspection" = "xyes" ; then
- AC_DEFINE([WITH_GOBJECT_INTROSPECTION], [1], [enable GObject introspection support])
- AC_SUBST(GOBJECT_INTROSPECTION_CFLAGS)
- AC_SUBST(GOBJECT_INTROSPECTION_LIBS)
- AC_SUBST([G_IR_SCANNER], [$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)])
- AC_SUBST([G_IR_COMPILER], [$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)])
- fi
-fi
-AM_CONDITIONAL([WITH_GOBJECT_INTROSPECTION], [test "x$enable_introspection" = "xyes"])
-
+GOBJECT_INTROSPECTION_CHECK($GOBJECT_INTROSPECTION_REQUIRED)
GTK_DOC_CHECK([1.10])
@@ -101,3 +77,14 @@ AC_CONFIG_FILES(Makefile
)
AC_OUTPUT
+echo "
+ LibPlanFahr $VERSION
+ ==============================================
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ Debug: ${enable_debug}
+
+ GObject Introspection: ${found_introspection}
+ Documentation: ${enable_gtk_doc}
+"