aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-21 15:57:11 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-24 08:39:05 +0100
commit891b34e2ef64f354474c4c6bec8e35f905e3c1db (patch)
tree9ff4373f980caa5eab84c4f3abaff6640783d817 /docs/reference/Makefile.am
Initial commit
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
new file mode 100644
index 0000000..0f77dbb
--- /dev/null
+++ b/docs/reference/Makefile.am
@@ -0,0 +1,70 @@
+## Process this file with automake to produce Makefile.in
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module
+DOC_MODULE=libplanfahr-0.0
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting functions and macros.
+DOC_SOURCE_DIR=../../src
+
+# Extra options to supply to gtkdoc-scan.
+SCAN_OPTIONS='--rebuild-types'
+
+# Extra options to supply to gtkdoc-scangobj.
+SCANGOBJ_OPTIONS=
+
+# Extra options to supply to gtkdoc-mkdb.
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref.
+FIXXREF_OPTIONS=
+
+# Used for dependencies.
+HFILE_GLOB=
+CFILE_GLOB=
+
+# Header files to ignore when scanning.
+IGNORE_HFILES = \
+ planfahr.h \
+ de-db.h \
+ hafas-bin6.h \
+ $(NULL)
+
+# Images to copy into HTML directory.
+HTML_IMAGES =
+
+# Extra XML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files = \
+ build-howto.xml \
+ $(NULL)
+
+# Other files to distribute.
+extra_files =
+
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GLIB_CFLAGS) \
+ $(XML_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/src/libplanfahr-0.0.la \
+ $(GLIB_LIBS)
+
+# include common portion ...
+include $(top_srcdir)/gtk-doc.make
+
+# kludges
+$(srcdir)/tmpl/*.sgml:
+
+clean: clean-am
+ rm -rf tmpl