aboutsummaryrefslogtreecommitdiff
path: root/libplanfahr/providers/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libplanfahr/providers/tests/Makefile.am')
-rw-r--r--libplanfahr/providers/tests/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/libplanfahr/providers/tests/Makefile.am b/libplanfahr/providers/tests/Makefile.am
new file mode 100644
index 0000000..d3ba939
--- /dev/null
+++ b/libplanfahr/providers/tests/Makefile.am
@@ -0,0 +1,58 @@
+include $(top_srcdir)/flymake.mk
+
+check_PROGRAMS = hafas-bin6 hafas-bin6-format
+
+AM_CPPFLAGS = \
+ -DLIBPLANFAHR_COMPILATION \
+ -DLPF_TEST_SRCDIR=\""$(abs_srcdir)"\" \
+ $(GLIB2_CFLAGS) \
+ $(GIO2_CFLAGS) \
+ $(GOBJECT2_CFLAGS) \
+ $(GTHREAD2_CFLAGS) \
+ $(LIBXML2_CFLAGS) \
+ $(WARN_CFLAGS) \
+ -I$(top_srcdir)/libplanfahr \
+ $(NULL)
+
+LDADD = \
+ $(top_builddir)/libplanfahr/libplanfahr-0.0.la \
+ $(GLIB2_LIBS) \
+ $(GIO2_LIBS) \
+ $(GOBJECT2_LIBS) \
+ $(GTHREAD2_LIBS) \
+ $(NULL)
+
+hafas_bin6_SOURCES = \
+ hafas-bin6.c \
+ $(NULL)
+
+hafas_bin6_CFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBSOUP_CFLAGS) \
+ $(LIBXML2_CFLAGS) \
+ $(NULL)
+hafas_bin6_LDADD = \
+ ../libplanfahr-provider-de-db.la \
+ $(LDADD) \
+ $(LIBSOUP_LIBS) \
+ $(LIBXML2_LIBS) \
+ $(NULL)
+
+hafas_bin6_format_SOURCES = \
+ hafas-bin6-format.c \
+ ../hafas-bin6-format.h \
+ $(NULL)
+hafas_bin6_format_CFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(NULL)
+hafas_bin6_format_LDADD = \
+ $(LDADD) \
+ $(NULL)
+
+
+uninstalled_testdir = tests/
+dist_uninstalled_test_DATA = \
+ hafas-bin-6-station-query-1.bin \
+ $(NULL)
+
+TESTS = $(check_PROGRAMS)