aboutsummaryrefslogtreecommitdiff
path: root/libplanfahr/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libplanfahr/tests/Makefile.am')
-rw-r--r--libplanfahr/tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/libplanfahr/tests/Makefile.am b/libplanfahr/tests/Makefile.am
index 9b1f55d..77d07d9 100644
--- a/libplanfahr/tests/Makefile.am
+++ b/libplanfahr/tests/Makefile.am
@@ -2,8 +2,9 @@ include $(top_srcdir)/flymake.mk
include $(top_srcdir)/glib-tap.mk
test_programs = \
- lpf-loc \
lpf-manager \
+ lpf-loc \
+ lpf-trip \
$(NULL)
AM_CPPFLAGS = \
@@ -59,6 +60,22 @@ lpf_loc_LDADD = \
$(LIBXML2_LIBS) \
$(NULL)
+lpf_trip_SOURCES = \
+ lpf-trip.c \
+ $(NULL)
+
+lpf_trip_CFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBSOUP_CFLAGS) \
+ $(LIBXML2_CFLAGS) \
+ $(NULL)
+lpf_trip_LDADD = \
+ ../providers/libplanfahr-provider-test-test.la \
+ $(LDADD) \
+ $(LIBSOUP_LIBS) \
+ $(LIBXML2_LIBS) \
+ $(NULL)
+
dist_test_data = \
$(NULL)