aboutsummaryrefslogtreecommitdiff
path: root/libplanfahr/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libplanfahr/tests/Makefile.am')
-rw-r--r--libplanfahr/tests/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/libplanfahr/tests/Makefile.am b/libplanfahr/tests/Makefile.am
index c36748e..9b1f55d 100644
--- a/libplanfahr/tests/Makefile.am
+++ b/libplanfahr/tests/Makefile.am
@@ -1,7 +1,10 @@
include $(top_srcdir)/flymake.mk
include $(top_srcdir)/glib-tap.mk
-test_programs = lpf-manager
+test_programs = \
+ lpf-loc \
+ lpf-manager \
+ $(NULL)
AM_CPPFLAGS = \
-DLIBPLANFAHR_COMPILATION \
@@ -40,6 +43,22 @@ lpf_manager_LDADD = \
$(LIBXML2_LIBS) \
$(NULL)
+lpf_loc_SOURCES = \
+ lpf-loc.c \
+ $(NULL)
+
+lpf_loc_CFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBSOUP_CFLAGS) \
+ $(LIBXML2_CFLAGS) \
+ $(NULL)
+lpf_loc_LDADD = \
+ ../providers/libplanfahr-provider-test-test.la \
+ $(LDADD) \
+ $(LIBSOUP_LIBS) \
+ $(LIBXML2_LIBS) \
+ $(NULL)
+
dist_test_data = \
$(NULL)