summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-03-13 13:07:47 +0100
committerGuido Günther <agx@sigxcpu.org>2016-03-13 13:07:47 +0100
commitd9619973de807f74da4fd595b7719385a6dcfc93 (patch)
tree7a48306d3ccf65be63e29a6c449e6321901876db /Makefile.am
parent4064e8bd795c70efe4a303cd36451a99ea67f8c4 (diff)
parent04ba0f1c1efc825d49e1486dcd18df59e1df0805 (diff)
Merge branch 'nm-1.1'v1.1.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b35207..24174e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,11 +13,18 @@ endif
dbusservicedir = $(sysconfdir)/dbus-1/system.d
dbusservice_DATA = nm-iodine-service.conf
-nmvpnservicedir = $(sysconfdir)/NetworkManager/VPN
+nmvpnservicedir = $(NM_VPN_SERVICE_DIR)
nmvpnservice_DATA = nm-iodine-service.name
+if WITH_LIBNM_GLIB
+nmvpnoldservicedir = $(sysconfdir)/NetworkManager/VPN
+nmvpnoldservice_DATA = nm-iodine-service.name
+endif
+
nm-iodine-service.name: $(srcdir)/nm-iodine-service.name.in
- sed -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' $< >$@
+ sed -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' \
+ -e 's|[@]PLUGINDIR[@]|$(libdir)/NetworkManager|g' \
+ $< >$@
DISTCHECK_CONFIGURE_FLAGS = --enable-more-warnings=yes