summaryrefslogtreecommitdiff
path: root/development/debian_packages_in_git.mdwn
diff options
context:
space:
mode:
authoragx <agx@web>2009-10-04 15:52:00 +0200
committerWiki User <wikwik@wiki.sigxcpu.org>2009-10-04 15:52:00 +0200
commit07aba267e9d6309ab0bda940a343deaf84547320 (patch)
treee169c2aa8b72279ca0c1b27dca6a5390e1aee7d2 /development/debian_packages_in_git.mdwn
parentf2f43129b4039f3df944a19462c7deaceb13b31b (diff)
howto backport
Diffstat (limited to 'development/debian_packages_in_git.mdwn')
-rw-r--r--development/debian_packages_in_git.mdwn23
1 files changed, 21 insertions, 2 deletions
diff --git a/development/debian_packages_in_git.mdwn b/development/debian_packages_in_git.mdwn
index e24d249..34fdc0e 100644
--- a/development/debian_packages_in_git.mdwn
+++ b/development/debian_packages_in_git.mdwn
@@ -1,6 +1,6 @@
[[!toc]]
-## Keeping debian/patches on a patch-queue branch
+# Keeping debian/patches on a patch-queue branch
I'm keeping all patches for a Debian package that is maintained on branch *foo* on a patch-queue branch *patch-queue/foo* since:
* one can easily work with the unpatched (*foo*) and patched (*patch-queue/foo*) branches
@@ -47,5 +47,24 @@ The easiest way is to not push out any patch-queue/* branches at all. They can b
However you *can* push out patch-queue branches. Other team members must just be aware that that branches in the *patch-queue/* namespace are being rebased frequently.
-## Cloning a repository
+# Cloning a repository
If you use *gbp-clone* instead of *git clone* to clone a remote repository it will automatically set up the *debian*, *upstream* and *pristine-tar* branches for you. The [manual](http://honk.sigxcpu.org/projects/git-buildpackage/manual-html/gbp.intro.html#GBP.REPOSITORY) explains the terminology.
+
+# Preparing a Backport
+I keep backports on a separate *bpo-<release>* branch like *bpo-lenny*:
+
+ git checkout bpo-lenny
+ git merge debian/<version-currently-in-testing>
+ <resolve conflict in debian/changelog>
+ <fix up stuff needed for backport>
+ gbp-lenny -sa -v <last-backported-version> --git-debian-branch=bpo-lenny
+
+*gbp-lenny* is a shell alias:
+
+ alias gbp-lenny='nice -19 git-buildpackage --git-builder=gbp-cowbuilder-lenny'
+
+and *gbp-cowbuilder-lenny* uses */usr/share/doc/git-buildpackage/examples/gbp-cowbuilder-sid*:
+
+ ln -s /usr/share/doc/git-buildpackage/examples/gbp-cowbuilder-sid ~/bin/gbp-cowbuilder-lenny
+
+