summaryrefslogtreecommitdiff
path: root/development/debian_packages_in_git.mdwn
diff options
context:
space:
mode:
authoragx <agx@web>2010-05-15 20:37:55 +0200
committerWiki User <wikwik@wiki.sigxcpu.org>2010-05-15 20:37:55 +0200
commit33c1e0fc244d2c59b43f928869c37331f3f8ad93 (patch)
treecfb89f0811cf960c03076e579cb85ce260fc5086 /development/debian_packages_in_git.mdwn
parentf45cd67df6bf1e19d3eaea2ff16f2e0fb651e28d (diff)
Add some notes about 3.0 (quilt)
Diffstat (limited to 'development/debian_packages_in_git.mdwn')
-rw-r--r--development/debian_packages_in_git.mdwn22
1 files changed, 21 insertions, 1 deletions
diff --git a/development/debian_packages_in_git.mdwn b/development/debian_packages_in_git.mdwn
index 7886e82..c52948b 100644
--- a/development/debian_packages_in_git.mdwn
+++ b/development/debian_packages_in_git.mdwn
@@ -30,7 +30,10 @@ Assuming the Debian source package has it's patches in *debian/patches* and thes
gbp-pq export
-* commit the result
+* commit the result either by using *gbp-add-patch* or simply
+
+ git commit -a debian/changelog
+
* update *debian/changelog* (e.g. by running "git-dch -S -a")
* build the package
* after importing a new upstream version you can use the following commands to refresh *debian/patches*:
@@ -47,6 +50,23 @@ The easiest way is to not push out any patch-queue/* branches at all. They can b
However you *can* push out patch-queue branches. Other team members must just be aware that that branches in the *patch-queue/* namespace are being rebased frequently.
+# Working with 3.0 (quilt) packges
+The 3.0 (quilt) format applies the patches in *debian/patches* automatically when building a source package.
+If you want your debian branch to contain the unpatched source there are several ways to handle this:
+
+## Using --git-export-dir
+If you're using option *--git-export-dir* option already there's no problem since the unpatched source tree gets exported before being built (and patch by dpkg-source). Since this implies an extra copy of the whole source tree (which might be slow for big projects) and it's not really necessary when using pbuilder the next method might be more appropriate.
+
+## Working from a patch-queue branch
+Instead of building from *master* build from *patch-queue/master* prepared by *gbp-pq* as describe above. This branch has the patches already applied as dpkg-source expects it:
+
+ gbp-pq import
+ git-buildpackage --git-debian-branch=patch-queue/master
+Build and test...
+
+ git co master
+ gbp-pq export
+
# Cloning a repository
If you use *gbp-clone* instead of *git clone* to clone a remote repository it will automatically set up the *debian*, *upstream* and *pristine-tar* branches for you. The [manual](http://honk.sigxcpu.org/projects/git-buildpackage/manual-html/gbp.intro.html#GBP.REPOSITORY) explains the terminology.