aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-06-06 21:16:45 +0200
committerGuido Günther <agx@sigxcpu.org>2014-06-06 21:22:19 +0200
commitb2d73d33da16f497d27e95b9cf498b9adc9f9c80 (patch)
tree10f0659e0ae2e145d5330c4f832447f6d93db97e /data/Makefile.am
parent9cf173763b4d21178276f228feceb799b0ce12c6 (diff)
Add appdata file
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 2b5580a..ad4e00f 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -15,14 +15,21 @@ gsettings_SCHEMAS = org.gnome.PrepaidManager.gschema.xml
gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
$(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+@INTLTOOL_XML_RULE@
+appdatadir = $(datadir)/appdata
+appdata_in_files = prepaid-manager-applet.appdata.xml.in
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
all-local: gschemas.compiled
EXTRA_DIST = \
org.gnome.PrepaidManager.gschema.xml.in.in \
+ $(appdata_in_files) \
$(NULL)
CLEANFILES = \
$(gsettings_SCHEMAS) \
gschemas.compiled \
+ $(appdata_DATA) \
$(NULL)