aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-07-02 16:11:08 +0200
committerGuido Günther <agx@sigxcpu.org>2011-07-05 22:33:32 +0200
commit2df5d870e2b560f63da123f586fc5e5456d42906 (patch)
tree86de01a857990ea56864e3e47049cb131803abdd /data/icons/Makefile.am
parentc44bb1e2193bcbe09bbdb446994301ee01624b18 (diff)
Add application icon
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..2f415b8
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,14 @@
+SUBDIRS = scalable 128x128 64x64 48x48 32x32
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi