aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:23 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:23 +0100
commit7fbee6ce27176bfc7ae9b34a4de9452cf5f6fa43 (patch)
tree5cabb0ab457846912d99ef675160be0dce4fbe6f /Makefile.am
parentdc645b92b9a7db3076ae34986ac219d01677d124 (diff)
Imported Upstream version 0.4+git.20110124t203624.00b6cceupstream/0.4+git.20110124t203624.00b6cce
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 276a276..4132bc9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,11 @@
+XSLTPROC = xsltproc --xinclude --nonet
+
+XMLS = $(wildcard introspection/*.xml)
+
if WITH_DOCS
all:
-XSLTPROC = xsltproc --xinclude --nonet
-
-XMLS = $(wildcard introspection/mm-*.xml)
# Figure out if we need ASYNC_INTROSPECT and add it later
GENERATED_FILES = \
@@ -42,16 +43,27 @@ dbusactivationdir = $(datadir)/dbus-1/system-services
dbusactivation_in_files = org.freedesktop.ModemManager.service.in
dbusactivation_DATA = $(dbusactivation_in_files:.service.in=.service)
+includedir = @includedir@/mm
+
+include_HEADERS = include/mm-modem.h
+
+include/mm-modem.h: $(XMLS) introspection/all.xml header-generator.xsl
+ @install -d include
+ $(XSLTPROC) header-generator.xsl introspection/all.xml > $@
+
%service: %service.in
$(edit) $< >$@
+xmldir = $(datadir)/dbus-1/interfaces
+xml_DATA = $(XMLS)
+
edit = @sed \
-e 's|@sbindir[@]|$(sbindir)|g' \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
-e 's|@libexecdir[@]|$(libexecdir)|g'
-DISTCHECK_CONFIGURE_FLAGS = --with-udev-base-dir=$dc_install_base
+DISTCHECK_CONFIGURE_FLAGS = --with-udev-base-dir=$dc_install_base --with-tests=yes
INTLTOOL_FILES = \
intltool-extract.in \
@@ -68,6 +80,7 @@ DISTCLEANFILES = \
EXTRA_DIST = \
doc-generator.xsl \
+ header-generator.xsl \
$(dbusactivation_in_files) \
$(INTLTOOL_FILES) \
$(dbusservice_file_polkit) \