aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2011-05-04 13:17:33 +0200
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:25 +0100
commitbbf8a053e07c66f336ed46a7fb6105dc30645596 (patch)
tree2a7a406bd84522eb64d355b222e95143462c8b0d /debian
parent5052359cd3ffb2ae94b31f915515609c07233547 (diff)
parent10d15c65fd10614c4085af390a9fbf390ab958b7 (diff)
Imported Debian patch 0.4+git.20110429t103114.863dbca-1debian/0.4+git.20110429t103114.863dbca-1
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source93
-rw-r--r--debian/changelog46
-rw-r--r--debian/compat2
-rw-r--r--debian/control6
-rw-r--r--debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch33
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules60
7 files changed, 175 insertions, 66 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..a2761fc
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,93 @@
+
+------------------------------------------------------
+
+ README.source - for Debian/Ubuntu modemmanager
+ Author: Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>
+
+------------------------------------------------------
+
+Content:
+
+ I. Packaging overview
+ II. Upstream (orig.tar.gz)
+ III. Efficient Upstream orig.tar.gz production
+ IV. Patching
+
+------
+
+I. Packaging overview
+
+ + Obtaining latest packaging:
+ bzr branch lp:~modemmanager/modemmanager/ubuntu
+
+ + this gives you a debian/ only bzr branch
+
+ + the suggested way to build is using bzr-builddeb; for that
+ 1. put the orig.tar.gz matching your debian/changelog in --orig-dir
+ of bzr-builddeb (default: ..)
+ 2. run: bzr bd --dont-purge
+ 3. this gives you a build tree and the results in --build-dir
+ and --result-dir
+
+ + if all you want to do is check the current package with full source, run:
+ ./debian/rules get-current-source
+ bzr bd-do
+
+
+II. Upstream (orig.tar.gz)
+
+The package provides means to easily grab the _current_ and the latest
+upstream snapshot of ModemManager.
+
+./debian/rules gets the pristine upstream snapshot for you then packs
+things up in a tarball orig.tar.gz.
+
+The nested tarball is packed using _gz_.
+
+Examples on how to get orig.tar.gz for snapshots:
+
+ + get latest upstream snapshot:
+ ./debian/rules get-orig-source
+
+ + get current upstream snapshot (by changelog):
+ ./debian/rules get-current-source
+
+
+III. Efficient Upstream orig.tar.gz production
+
+The packaging provides a feature to speed up the orig.tar.gz production by
+keeping a local mirror of the NetworkManager checkouts; this reduces the
+network overhead considerably and allows you to regularly create tarballs
+rather quickly. To do that, append LOCAL_BRANCH=/local/MM/checkout
+to your debian/rules invocation, e.g.
+
+ + produce latest upstream snapshot:
+ ./debian/rules get-orig-source LOCAL_BRANCH=~/ModemManager/
+
+ + produce current upstream snapshot (by changelog):
+ ./debian/rules get-current-source LOCAL_BRANCH=~/ModemManager/
+
+
+V. Patching
+
+We use quilt for the sake of efficiency to code and update patches.
+
+if you want to create a patch or write a patch, you can quickly get
+ready by first getting the orig.tar.gz, then using bzr-builddeb like
+so:
+
+ bzr bd-do
+
+Make sure your QUILT_PATCHES is set appropriately:
+
+ QUILT_PATCHES=debian/patches
+
+and start working on quilt patches as usual, e.g.
+
+ quilt push -a
+ quilt applied
+ quilt pop
+ quilt refresh
+ ...
+
+
diff --git a/debian/changelog b/debian/changelog
index 33447f9..000a468 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,49 @@
+modemmanager (0.4+git.20110429t103114.863dbca-1) unstable; urgency=low
+
+ [ Thomas Bechtold ]
+ * debian/rules, debian/control: migrate from CDBS to using dh
+
+ [ Mathieu Trudel-Lapierre ]
+ * upstream snapshot 2011-04-29 10:31:14 (GMT)
+ + 863dbca63132b820fca6c48a9c212f852752ee16
+ * debian/README.source: add instructions for using this packaging branch and
+ how to build from it; adapted from the NetworkManager package.
+ * debian/rules, debian/control: update control and rules to use dh-autoreconf
+ rather than just autoreconf.
+ * debian/control: bump Standards-Version to 3.9.2.
+ * debian/rules: re-add DEB_* variables which got dropped from the dh
+ migration, since we no longer include buildvars.mk.
+ * debian/patches/git-backport-e208c52-to-0c4b944.patch,
+ debian/patches/git-backport-verbose-cmee-errors-7d20acc.patch: dropped,
+ applied upstream.
+ * debian/control: bump debhelper Build-Depends to 8.
+ * debian/compat: bump to compat level 8, according to the debhelper update.
+ * debian/rules: cleanup extra files left behind by intltoolize.
+
+ -- Michael Biebl <biebl@debian.org> Wed, 04 May 2011 13:17:33 +0200
+
+modemmanager (0.4+git.20110124t203624.00b6cce-2ubuntu1) natty; urgency=low
+
+ * debian/patches/git-backport-e208c52-to-0c4b944.patch: backport a number of
+ upstream bug fixes:
+ - gsm: fix for parsing malformed Gobi CREG response
+ - core: allow plugins to handle custom init responses (LP: #712580)
+ - policy: loosen permissions somewhat for reading device info (kde#266807)
+ - logging: use glong for secs and usecs
+ - cdma: ensure the ActivationStateChanged signal exists
+ - log: fix spacing so messages line up
+ - simtech: add port tags for SCT U300 (Element Mobile)
+ - core: allow platform devices without a VID/PID
+ - zte: fix handling of Icera simple connect process
+ - icera: fix username and password ordering for authentication
+ * debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch: drop, included
+ in the above backports from upstream.
+ * debian/patches/git-backport-verbose-cmee-errors-7d20acc.patch: backport
+ patch to make sure error reporting is set to verbose when asking modems
+ about PIN status, so we get a useful message instead of a generic error.
+
+ -- Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com> Sun, 10 Apr 2011 18:16:54 -0400
+
modemmanager (0.4+git.20110124t203624.00b6cce-2) unstable; urgency=low
* debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch
diff --git a/debian/compat b/debian/compat
index 7f8f011..45a4fb7 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+8
diff --git a/debian/control b/debian/control
index 070331c..bed079e 100644
--- a/debian/control
+++ b/debian/control
@@ -3,16 +3,16 @@ Section: net
Priority: optional
Maintainer: Alexander Sack <asac@ubuntu.com>
Uploaders: Alexander Sack <asac@debian.org>, Michael Biebl <biebl@debian.org>, Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>
-Build-Depends: debhelper (>= 7),
+Build-Depends: debhelper (>= 8),
+ dh-autoreconf,
automake (>= 1:1.10), automake (<< 1:1.12),
- cdbs,
libtool,
libdbus-glib-1-dev (>= 0.86),
libglib2.0-dev (>= 2.18),
libgudev-1.0-dev,
xsltproc,
intltool
-Standards-Version: 3.9.1
+Standards-Version: 3.9.2
Vcs-Bzr: https://code.launchpad.net/~modemmanager/modemmanager/ubuntu
Package: modemmanager
diff --git a/debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch b/debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch
deleted file mode 100644
index dc8da09..0000000
--- a/debian/patches/0001-Use-type-glong-for-secs-and-usecs.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From c9772e14aa0bf4e252213b319b9211d7aef5bf15 Mon Sep 17 00:00:00 2001
-From: Michael Biebl <biebl@debian.org>
-Date: Fri, 25 Feb 2011 11:08:18 +0100
-Subject: [PATCH] Use type glong for secs and usecs
-
-GVariant defines tv_sec and tv_usec as type glong and suseconds_t is not
-guaranteed to be of type long on sparc, which results in a build
-failure.
-
-http://lxr.free-electrons.com/source/arch/sparc/include/asm/posix_types.h#L41
-https://buildd.debian.org/fetch.cgi?pkg=modemmanager&arch=sparc&ver=0.4%2Bgit.20110124t203624.00b6cce-1&stamp=1298595733&file=log&as=raw
----
- src/mm-log.c | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/mm-log.c b/src/mm-log.c
-index bcf806a..3e3bd83 100644
---- a/src/mm-log.c
-+++ b/src/mm-log.c
-@@ -77,8 +77,8 @@ _mm_log (const char *loc,
- g_get_current_time (&tv);
- snprintf (&tsbuf[0], sizeof (tsbuf), " [%09ld.%06ld]", tv.tv_sec, tv.tv_usec);
- } else if (ts_flags == TS_FLAG_REL) {
-- time_t secs;
-- suseconds_t usecs;
-+ glong secs;
-+ glong usecs;
-
- g_get_current_time (&tv);
- secs = tv.tv_sec - rel_start.tv_sec;
---
-1.7.4.1
-
diff --git a/debian/patches/series b/debian/patches/series
index 68338fc..235bfb9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,2 @@
# patches for modemmanager
qdl-blacklist.patch
-0001-Use-type-glong-for-secs-and-usecs.patch
diff --git a/debian/rules b/debian/rules
index 46391b0..b75af87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,30 +1,42 @@
#!/usr/bin/make -f
-DEB_AUTO_UPDATE_LIBTOOL = pre
-DEB_AUTO_UPDATE_AUTOHEADER = 2.50
-DEB_AUTO_UPDATE_AUTOCONF = 2.50
-
-# use automake 1.10 ... or 1.11
-ifneq (,$(wildcard /usr/bin/aclocal-1.11))
-DEB_AUTO_UPDATE_ACLOCAL = 1.11
-DEB_AUTO_UPDATE_AUTOMAKE = 1.11 -a -c -f
-else
-DEB_AUTO_UPDATE_ACLOCAL = 1.10
-DEB_AUTO_UPDATE_AUTOMAKE = 1.10 -a -c -f
-endif
+#For debhelper debugging
+#export DH_VERBOSE=1
-include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
+#always exclude any data from version control systems
+DH_ALWAYS_EXCLUDE=.svn:.git:.bzr
-DEB_MAJOR_VERSION := $(shell echo $(DEB_UPSTREAM_VERSION) | sed -e 's/git.*//')
+%:
+ dh $@ --with autoreconf
+
+override_dh_autoreconf:
+ intltoolize --force
+ dh_autoreconf
+
+override_dh_autoreconf_clean:
+ dh_autoreconf_clean
+ rm -f intltool-*.in po/Makefile.in.in m4/intltool.m4 || true
-DEB_DH_MAKESHLIBS_ARGS_modemmanager := -X/usr/lib/ModemManager/ -X/usr/lib/pppd/
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --with-docs
-DEB_INSTALL_DOCS_ALL := README AUTHORS docs/spec.html
+override_dh_makeshlibs:
+ dh_makeshlibs -X/usr/lib/ModemManager/ -X/usr/lib/pppd/
+
+override_dh_install:
+ find $(CURDIR)/debian/modemmanager/ -name \*.a | xargs rm
+ find $(CURDIR)/debian/modemmanager/ -name \*.la | xargs rm
+ dh_install
-DEB_CONFIGURE_EXTRA_FLAGS += \
- --with-docs \
- $(NULL)
+override_dh_installdocs:
+ dh_installdocs -A README AUTHORS docs/spec.html
+
+DEB_SOURCE_PACKAGE := $(shell dpkg-parsechangelog | egrep '^Source:' | cut -f 2 -d ' ')
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_MAJOR_VERSION := $(shell echo $(DEB_UPSTREAM_VERSION) | sed -e 's/git.*//')
GIT_URL := git://anongit.freedesktop.org/ModemManager/ModemManager
GIT_BRANCH := "master"
@@ -34,10 +46,6 @@ ifneq (,$(LOCAL_BRANCH))
LOCAL_REAL_BRANCH = $(realpath $(LOCAL_BRANCH))
endif
-pre-build::
- # run intltoolize before updating the build system
- intltoolize -f
-
GET_SOURCE = \
set -e; \
tmpdir=`mktemp -d -t`; \
@@ -57,10 +65,6 @@ GET_SOURCE = \
cd ..; tar --exclude=.git -czf $(CURDIR)/$(DEB_SOURCE_PACKAGE)_$$upstream_version.orig.tar.gz `ls | head -n 1`; \
cd $(CURDIR); rm -rf $$tmpdir;
-binary-post-install/modemmanager::
- find $(CURDIR)/debian/modemmanager/ -name \*.a | xargs rm
- find $(CURDIR)/debian/modemmanager/ -name \*.la | xargs rm
-
get-current-source:: $(if $(LOCAL_BRANCH), update-local-branch)
set -e; if echo $(DEB_VERSION) | grep -c "git" > /dev/null; \
then \