aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2010-06-27 02:46:38 +0200
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:23 +0100
commitc71fd20fa3fe751b50321179c8e4a547d369e1aa (patch)
tree5f09d7900816a3e46d7d7acfe0ddf809b876f202 /debian
parentb0627eff1011755dfecff52a07a81801f876c457 (diff)
parentdc645b92b9a7db3076ae34986ac219d01677d124 (diff)
Imported Debian patch 0.4+git.20100624t180933.6e79d15-1debian/0.4+git.20100624t180933.6e79d15-1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog23
-rw-r--r--debian/control5
-rw-r--r--debian/patches/01-termios.patch82
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/watch2
6 files changed, 30 insertions, 87 deletions
diff --git a/debian/changelog b/debian/changelog
index a0c37d2..71feb5d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,26 @@
+modemmanager (0.4+git.20100624t180933.6e79d15-1) unstable; urgency=low
+
+ [ Michael Biebl ]
+ * New upstream release. (Closes: #585957)
+ * Drop debian/patches/01-termios.patch, merged upstream.
+ * debian/rules
+ - Drop aclocal workaround, no longer required.
+ - Add intltoolize call to pre-build.
+
+ [ Mathieu Trudel-Lapierre ]
+ * upstream snapshot 2010-06-24 18:09:33 (GMT)
+ + 6e79d153efc30fb2030536f7f795c19ad4a0661a
+ * Add myself to Uploaders.
+ - update debian/control
+
+ [ Michael Biebl ]
+ * Use watch file to track new upstream releases.
+ - Add debian/watch.
+ * Add Build-Depends on intltool.
+ - Update debian/control.
+
+ -- Michael Biebl <biebl@debian.org> Sun, 27 Jun 2010 02:46:38 +0200
+
modemmanager (0.3-2) unstable; urgency=low
[ Alexander Sack ]
diff --git a/debian/control b/debian/control
index 4751436..b256025 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: modemmanager
Section: net
Priority: optional
Maintainer: Alexander Sack <asac@ubuntu.com>
-Uploaders: Alexander Sack <asac@debian.org>, Michael Biebl <biebl@debian.org>
+Uploaders: Alexander Sack <asac@debian.org>, Michael Biebl <biebl@debian.org>, Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>
Build-Depends: debhelper (>= 7),
automake (>= 1:1.10), automake (<< 1:1.12),
cdbs,
@@ -11,7 +11,8 @@ Build-Depends: debhelper (>= 7),
libdbus-glib-1-dev (>= 0.75),
libglib2.0-dev (>= 2.18),
libgudev-1.0-dev,
- xsltproc
+ xsltproc,
+ intltool
Standards-Version: 3.8.4
Vcs-Bzr: https://code.launchpad.net/~modemmanager/modemmanager/ubuntu
diff --git a/debian/patches/01-termios.patch b/debian/patches/01-termios.patch
deleted file mode 100644
index f4ee4eb..0000000
--- a/debian/patches/01-termios.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Description: Fix FTBFS on alpha by using the POSIX.1 struct termios interface
- instead of the obsolete struct termio ioctl interface.
-Author: Michael Biebl <biebl@debian.org>
-Debian-Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=570661
-Index: modemmanager-0.3/src/mm-serial-port.c
-===================================================================
---- modemmanager-0.3.orig/src/mm-serial-port.c 2010-01-02 03:51:21.000000000 +0100
-+++ modemmanager-0.3/src/mm-serial-port.c 2010-03-01 17:59:27.457439379 +0100
-@@ -18,7 +18,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
--#include <termio.h>
-+#include <termios.h>
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-@@ -148,12 +148,12 @@
- mm_serial_port_print_config (MMSerialPort *port, const char *detail)
- {
- MMSerialPortPrivate *priv = MM_SERIAL_PORT_GET_PRIVATE (port);
-- struct termio stbuf;
-+ struct termios stbuf;
- int err;
-
-- err = ioctl (priv->fd, TCGETA, &stbuf);
-+ err = tcgetattr (priv->fd, &stbuf);
- if (err) {
-- g_warning ("*** %s (%s): (%s) TCGETA error %d",
-+ g_warning ("*** %s (%s): (%s) tcgetattr() error %d",
- __func__, detail, mm_port_get_device (MM_PORT (port)), errno);
- return;
- }
-@@ -330,7 +330,7 @@
- config_fd (MMSerialPort *self, GError **error)
- {
- MMSerialPortPrivate *priv = MM_SERIAL_PORT_GET_PRIVATE (self);
-- struct termio stbuf;
-+ struct termios stbuf;
- int speed;
- int bits;
- int parity;
-@@ -341,9 +341,9 @@
- parity = parse_parity (priv->parity);
- stopbits = parse_stopbits (priv->stopbits);
-
-- memset (&stbuf, 0, sizeof (struct termio));
-- if (ioctl (priv->fd, TCGETA, &stbuf) != 0) {
-- g_warning ("%s (%s): TCGETA error: %d",
-+ memset (&stbuf, 0, sizeof (struct termios));
-+ if (tcgetattr (priv->fd, &stbuf) != 0) {
-+ g_warning ("%s (%s): tcgetattr() error: %d",
- __func__,
- mm_port_get_device (MM_PORT (self)),
- errno);
-@@ -360,7 +360,7 @@
- stbuf.c_cflag &= ~(CBAUD | CSIZE | CSTOPB | CLOCAL | PARENB);
- stbuf.c_cflag |= (speed | bits | CREAD | 0 | parity | stopbits);
-
-- if (ioctl (priv->fd, TCSETA, &stbuf) < 0) {
-+ if (tcsetattr (priv->fd, TCSANOW, &stbuf) < 0) {
- g_set_error (error,
- MM_MODEM_ERROR,
- MM_MODEM_ERROR_GENERAL,
-@@ -825,7 +825,7 @@
- return FALSE;
- }
-
-- if (ioctl (priv->fd, TCGETA, &priv->old_t) < 0) {
-+ if (tcgetattr (priv->fd, &priv->old_t) < 0) {
- g_set_error (error, MM_SERIAL_ERROR, MM_SERIAL_OPEN_FAILED,
- "Could not open serial device %s: %s", device, strerror (errno));
- close (priv->fd);
-@@ -883,7 +883,7 @@
- priv->flash_id = 0;
- }
-
-- ioctl (priv->fd, TCSETA, &priv->old_t);
-+ tcsetattr (priv->fd, TCSANOW, &priv->old_t);
- close (priv->fd);
- priv->fd = -1;
- }
diff --git a/debian/patches/series b/debian/patches/series
index e004a69..efe1532 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
# patches for modemmanager
-01-termios.patch
diff --git a/debian/rules b/debian/rules
index a722624..0c429a7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,8 +36,8 @@ LOCAL_REAL_BRANCH = $(realpath $(LOCAL_BRANCH))
endif
pre-build::
- # workaround cdbs that does not run aclocal if no aclocal.m4 file exists
- touch aclocal.m4
+ # run intltoolize before updating the build system
+ intltoolize -f
GET_SOURCE = \
set -e; \
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..11e0972
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://ftp.gnome.org/pub/gnome/sources/ModemManager/([\d\.]+)/ModemManager-(.*)\.tar\.gz