aboutsummaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:30 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:30 +0100
commit13ed135b9ae78c692dc359976eb8b54d0a3629b8 (patch)
treeae2ea713ad51d73980cf83db1411d6589dac5e8b /include/Makefile.am
parent14d771b90f5a7d3887e5e900d1fb4737477ad305 (diff)
Imported Upstream version 0.7.991upstream/0.7.991
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644
index 0000000..f0a69d9
--- /dev/null
+++ b/include/Makefile.am
@@ -0,0 +1,17 @@
+XSLTPROC = xsltproc --xinclude --nonet
+
+XMLS = $(wildcard $(top_srcdir)/introspection/*.xml)
+
+includedir = @includedir@/ModemManager
+
+include_HEADERS = \
+ ModemManager-names.h \
+ ModemManager-enums.h \
+ ModemManager-errors.h \
+ ModemManager.h
+
+ModemManager-names.h: $(XMLS) $(top_srcdir)/build-aux/header-generator.xsl
+ $(AM_V_GEN) $(XSLTPROC) $(top_srcdir)/build-aux/header-generator.xsl $(top_srcdir)/introspection/all.xml > $@
+
+CLEANFILES = \
+ ModemManager-names.h