aboutsummaryrefslogtreecommitdiff
path: root/libmm-glib/Makefile.am
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-06-11 10:35:42 -0400
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:35 +0100
commitff30c94ae57db55d37453d4dd28d9eef2cfc5685 (patch)
treec04f1f7e3de8b1c0a4a08cd46c04be04611bbca1 /libmm-glib/Makefile.am
parent995105da294e1a7ea6cf6f640455dd9b73b08f49 (diff)
parent13ed135b9ae78c692dc359976eb8b54d0a3629b8 (diff)
Imported Debian patch 0.7.991-1debian/0.7.991-1
Diffstat (limited to 'libmm-glib/Makefile.am')
-rw-r--r--libmm-glib/Makefile.am108
1 files changed, 108 insertions, 0 deletions
diff --git a/libmm-glib/Makefile.am b/libmm-glib/Makefile.am
new file mode 100644
index 0000000..b189b91
--- /dev/null
+++ b/libmm-glib/Makefile.am
@@ -0,0 +1,108 @@
+SUBDIRS = generated . tests
+
+lib_LTLIBRARIES = libmm-glib.la
+
+libmm_glib_la_SOURCES = \
+ libmm-glib.h \
+ mm-helpers.h \
+ mm-helper-types.h \
+ mm-manager.h \
+ mm-manager.c \
+ mm-object.h \
+ mm-object.c \
+ mm-modem.h \
+ mm-modem.c \
+ mm-modem-3gpp.h \
+ mm-modem-3gpp.c \
+ mm-modem-3gpp-ussd.h \
+ mm-modem-3gpp-ussd.c \
+ mm-modem-cdma.h \
+ mm-modem-cdma.c \
+ mm-modem-simple.h \
+ mm-modem-simple.c \
+ mm-modem-location.h \
+ mm-modem-location.c \
+ mm-modem-time.h \
+ mm-modem-time.c \
+ mm-modem-firmware.h \
+ mm-modem-firmware.c \
+ mm-sim.h \
+ mm-sim.c \
+ mm-sms.h \
+ mm-sms.c \
+ mm-modem-messaging.h \
+ mm-modem-messaging.c \
+ mm-bearer.h \
+ mm-bearer.c \
+ mm-common-helpers.h \
+ mm-common-helpers.c \
+ mm-simple-status.h \
+ mm-simple-status.c \
+ mm-simple-connect-properties.h \
+ mm-simple-connect-properties.c \
+ mm-bearer-properties.h \
+ mm-bearer-properties.c \
+ mm-sms-properties.h \
+ mm-sms-properties.c \
+ mm-bearer-ip-config.h \
+ mm-bearer-ip-config.c \
+ mm-location-common.h \
+ mm-location-3gpp.h \
+ mm-location-3gpp.c \
+ mm-location-gps-raw.h \
+ mm-location-gps-raw.c \
+ mm-location-gps-nmea.h \
+ mm-location-gps-nmea.c \
+ mm-location-cdma-bs.h \
+ mm-location-cdma-bs.c \
+ mm-unlock-retries.h \
+ mm-unlock-retries.c \
+ mm-network-timezone.h \
+ mm-network-timezone.c \
+ mm-firmware-properties.h \
+ mm-firmware-properties.c
+
+libmm_glib_la_CPPFLAGS = \
+ $(LIBMM_GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ -I${top_srcdir}/libmm-glib/generated \
+ -I${top_builddir}/libmm-glib/generated \
+ -DLIBMM_GLIB_COMPILATION
+
+libmm_glib_la_LIBADD = \
+ ${top_builddir}/libmm-glib/generated/libmm-generated.la \
+ $(LIBMM_GLIB_LIBS)
+
+includedir = @includedir@/libmm-glib
+include_HEADERS = \
+ libmm-glib.h \
+ mm-helper-types.h \
+ mm-manager.h \
+ mm-object.h \
+ mm-modem.h \
+ mm-modem-3gpp.h \
+ mm-modem-3gpp-ussd.h \
+ mm-modem-cdma.h \
+ mm-modem-messaging.h \
+ mm-modem-location.h \
+ mm-modem-time.h \
+ mm-modem-firmware.h \
+ mm-modem-simple.h \
+ mm-sim.h \
+ mm-sms.h \
+ mm-bearer.h \
+ mm-simple-status.h \
+ mm-simple-connect-properties.h \
+ mm-bearer-properties.h \
+ mm-sms-properties.h \
+ mm-bearer-ip-config.h \
+ mm-location-common.h \
+ mm-location-3gpp.h \
+ mm-location-gps-nmea.h \
+ mm-location-gps-raw.h \
+ mm-location-cdma-bs.h \
+ mm-unlock-retries.h \
+ mm-network-timezone.h \
+ mm-firmware-properties.h